Bug 212430 - HPLIP / sane/ fc6 / HP psc 2110 no scanner detection
HPLIP / sane/ fc6 / HP psc 2110 no scanner detection
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Depends On:
  Show dependency treegraph
Reported: 2006-10-26 14:59 EDT by Krzysztof "Uosiu" Hajdamowicz
Modified: 2008-06-16 21:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Results from sane-find-scanner and scanimage -L (1.01 KB, text/plain)
2008-03-03 18:43 EST, Chris Schembari
no flags Details

  None (edit)
Description Krzysztof "Uosiu" Hajdamowicz 2006-10-26 14:59:18 EDT
Description of problem:

Version-Release number of selected component (if applicable):
[ root@smekta ] ~ #rpm -qa |grep sane && rpm -qa |grep hplip

Steps to Reproduce:
1) Install fc6
2) For sure restart device
3) Run scanimage -L
Actual results:
Scanner not detected, printing work perfectly

Expected results:
Everything should work perfectly ;)

Additional info:
Scanner worked in fc5 after 3 months since premiere, NOT worked in fc6 test3 and
not working in fc6

[ root@smekta ] ~ #service hplip start
Uruchamianie hpiod:                                        [  OK  ]
Uruchamianie hpssd:                                        [  OK  ]
[ root@smekta ] ~ #ps aux | grep hpssd
root      7232  0.0  0.6  12892  4720 ?        S    20:46   0:00 python ./hpssd.py
root      7250  0.0  0.0   3908   736 pts/5    S+   20:46   0:00 grep hpssd
[ root@smekta ] ~ #/usr/lib/cups/backend/hp
direct hp:/usb/PSC_2100_Series?serial=MY2ASD70KY0F "HP PSC 2100 Series" "HP PSC
2100 Series USB MY2ASD70KY0F HPLIP" "MFG:HP;MDL:PSC 2100
Series;CLS:PRINTER;DES:PSC 2100 Series;SN:MY2ASD70KY0F;"
[ root@smekta ] ~ #scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[ root@smekta ] ~ #cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1     localhost.localdomain   localhost localhost
[ root@smekta ] ~ #
Comment 1 cornel panceac 2006-11-01 08:20:31 EST
my scanner (canon lide 20) works in: fc{4,5}, centos 4.4 and is detected by
sane-find-scanner in fc6 but, indeed, scanimage -L shows nothing, xsane starts
and close without finding any device etc.

$ sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x220d [CanoScan],
chip=LM9832/3) at libusb:001:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

$ scanimage -L

$ rpm -qa | grep sane
Comment 2 Need Real Name 2007-01-29 17:28:22 EST
I have the same problem with an HP PSC 1315xi. It was working under FC6 on Jan
10th. No changes to my hardware, so I think one of the updates probably broke
it. I typically update with yum once a week and can provide the revelent
portions of /var/log/yum.log if that will help. I have tried backing out to
earlier versions for hplip hpijs libsane-hpaio and hal-cups-utils but that
didn't help.

I see these errors in /var/log/messages when I try to access the scanner:
hpiod: service busy uri:hp:/usb/psc_1310_series_?serial=MY49ECC422O2
Device::ChannelOpen: HP-MESSAGE io/hpiod/device.cpp 1316 

I have had problems in past FC releases with the print subsystem holding the
printer open so the scanner subsystem couldn't get to it. Stopping and disabling
cups and rebooting didn't help in this case though.

hald seems to be creating a "psc_1310_series_" printer for me. Maybe that's
blocking access by sane? I don't know hald well enough to determine... Deleting
the printer it created didn't help any.

Comment 3 Need Real Name 2007-01-31 11:23:47 EST
After messing with this some more I broke every thing. Couldn't print, Couldn't
Scan. Couldn't get them working again. So I deleted all my printers with
system-config-printer. I removed the newer versions of the following packages
with "rpm -e --nodeps" and then installed the following versions:


Cold reboot, turned on printer. Found printer named "psc_1310_series_" had been
added automatically. 
Description "Added by HAL". 
Device URI:
Make and Model: HP PSC 1310 Foomatic/hpijs (recommended)

I was able to print a test page.
Scanning worked.
Printing no longer worked.
Scanning still worked.

In system-config-printer, I changed the Device URI to:

service cups stop
service hplip stop
service hplip start
service cups start

lprm'ed all the jobs in queue.
ls -l | head | lpr  worked.
scanning worked
ls -l | head | lpr  still worked.

Did a cold reboot and verified it still works.

I don't know which of those new rpms broke things. I don't have time to continue
experimenting right now. 
Comment 4 Maxime Carron 2007-02-27 12:35:49 EST
I have the same problem with HP 1315 (all-in-one)

Some informations wich could be useful :
- it works on fc5 (with the latest updates)
- it works on FC6 (out of the box)
- it doesn't work on fc6 with the latest updates
Comment 5 Nils Philippsen 2007-06-13 03:23:32 EDT
All, please try in whether the first FC5 kernel works:


Install it ("rpm -ivh --oldpackage ..."), reboot into that kernel and report
back whether this makes a difference.
Comment 6 Mace Moneta 2007-09-21 22:55:09 EDT
I had this problem today with an Epson Perfection 1240U on a fully updated FC6
system.  I had the following installed:


I downgraded the packages to the version in the core repository:


Immediately, the scanner was recognized and worked again.
Comment 7 Nils Philippsen 2007-09-28 11:29:04 EDT
(In reply to comment #6)
> I had this problem today with an Epson Perfection 1240U on a fully updated FC6
> system.  I had the following installed:
> libsane-hpaio-1.7.4a-2.fc6
> sane-backends-1.0.18-15.fc6
> sane-backends-libs-1.0.18-15.fc6
> sane-backends-libs-1.0.18-15.fc6
> sane-frontends-1.0.14-1.2.2
> xsane-0.994-2.fc6
> xsane-gimp-0.994-2.fc6
> I downgraded the packages to the version in the core repository:
> xsane-gimp-0.991-2.fc6
> sane-backends-libs-1.0.18-5.fc6
> sane-frontends-1.0.14-1.2.2
> xsane-0.991-2.fc6
> libsane-hpaio-1.6.7-4
> sane-backends-1.0.18-5.fc6
> Immediately, the scanner was recognized and worked again.

Please try if downgrading only sane-backends and sane-backends-libs helps. Thanks.
Comment 8 Mace Moneta 2007-09-28 11:48:02 EDT
I'm now running:


The scanner is recognized and working properly with this configuration.
Comment 9 Chris Schembari 2008-03-03 18:43:17 EST
Created attachment 296689 [details]
Results from sane-find-scanner and scanimage -L
Comment 10 Chris Schembari 2008-03-03 18:47:53 EST
[See text file I just uploaded.]
I have the same problem with an HP PSC 1210 all-in-one device.  I used to be
able to print to this printer in FC1 (book edition) and FC6. While using FC6,
though, and now in F7, the device has displayed an "E" error message and hasn't
printed since then.  In Windows XP, it can scan but it shows an error message
that the printer has a paper jam, even though there is no paper inside it at
all.  This "phantom jam" appears to be unrelated, as even when it printed well
in both Linux and WinXP, and scanned in XP, it never could scan in Linux.
From its page on SF (http://hplip.sourceforge.net/install/install/index.html), I
installed the latest hplip package (2.8.2).  The included HP utility, hp-setup,
detects the USB device just fine, and so does sane-find-scanner.
  When I type "scanimage -L", however, the only device recognized as a 'scanner'
is my TV tuner card!! The scanner is not even listed.  The same results come
from launching XSANE and looking for devices.
Comment 11 Bug Zapper 2008-04-04 00:08:30 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 12 Nils Philippsen 2008-04-04 07:23:17 EDT
We have version 1.0.19 opf the sane-backends in Rawhide/F9 which contains many
fixes -- Would you try it out? I can then make a scratch-build of it for F8.
Comment 13 Nils Philippsen 2008-04-04 07:24:08 EDT
... or for F7, depending on what you need.
Comment 14 Bug Zapper 2008-05-14 08:03:54 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2008-06-16 21:14:15 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.