Bug 212450 - virt-manager created VMs use wrong amount of RAM
virt-manager created VMs use wrong amount of RAM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Hugh Brock
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 16:14 EDT by Need Real Name
Modified: 2008-01-10 23:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 23:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-10-26 16:14:35 EDT
A new VM created with VM manager was given a maximum amount of ram as 256 megs,
and an initial amount of ram of the same.
The monitor shows the initial amount as being 255 megs.
Comment 1 Daniel Berrange 2006-10-26 17:00:22 EDT
Looks like a rounding error in the display. Using the command line 'virsh
dominfo' command I see VMs used a fraction less RAM than the max limit (which I
think is expected due to way balloon driver works)

Max memory:     417792 kB
Used memory:    417532 kB

Converting this into MB, gives  408 MB, and 407.75 MB - looks like virt-manager
summary ought to round() the MB figure, rather than truncating the digits.
Comment 2 Red Hat Bugzilla 2007-07-24 22:06:21 EDT
change QA contact
Comment 3 Daniel Berrange 2007-09-27 17:01:50 EDT
Patch included upstream now

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=92b2fc9f9201

Will be included in a future update, most likely only to F7 or later though.

Note You need to log in before you can comment on or make changes to this bug.