Bug 212455 - Anaconda Bug after network setting
Summary: Anaconda Bug after network setting
Status: CLOSED DUPLICATE of bug 212018
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 6
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-26 20:34 UTC by adima
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 20:51:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Bug after network setting (76.53 KB, text/plain)
2006-10-26 20:34 UTC, adima
no flags Details

Description adima 2006-10-26 20:34:07 UTC
Description of problem:
Installation in aborted after configuring the network in static mode.

Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 69, in _netdevChanged
    if netdev.get("ipaddr"):
self.xml.get_widget("ipv4AddressEntry").set_text(netdev.get("ipaddr"))
AttributeError: 'NoneType' object has no attribute 'set_text'

Local variables in innermost frame:
val: eth0
netdev: DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.0.255
HWADDR=00:50:8D:EF:D4:3C
IPADDR=192.168.0.1
IPV6ADDR=
IPV6PREFIX=
NETMASK=255.255.255.0
NETWORK=192.168.0.0
ONBOOT=yes

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Setting the network in static mode disabling IP V6 (I think it's not a very
good thing to let the user entering an Ip address like 111111111111 without any
check regarding the IP format or a mask as before...) 
2.You can continue, but when you select extras or other package family, the
installation is aborted with a bug report as shown on top.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 adima 2006-10-26 20:34:07 UTC
Created attachment 139525 [details]
Anaconda Bug after network setting

Comment 2 Chris Lumens 2006-10-26 20:51:22 UTC

*** This bug has been marked as a duplicate of 212018 ***


Note You need to log in before you can comment on or make changes to this bug.