Bug 212473 - segfault with mod_authnz_ldap
segfault with mod_authnz_ldap
Status: CLOSED DUPLICATE of bug 188073
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 17:28 EDT by Jeff Strunk
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 17:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Strunk 2006-10-26 17:28:24 EDT
Description of problem:
When mod_authnz_ldap(included in the httpd package) is used, every time someone
authenticates(whether successfully or not) the httpd child process segfaults.

The LDAP server is Fedora DS 1.0.2.

The configuration section is:
<Location /svn-test/>
   #SSLRequireSSL
   DAV svn
   SVNParentPath /var/www/svn

   AuthType Basic
   AuthName "Enthought"
   AuthBasicProvider ldap
   AuthLDAPUrl ldap://ldap0.enthought/ou=People,dc=enthought?uid?sub NONE
AuthzLDAPAuthoritative off
require valid-user
</Location>

The log output is:
[Thu Oct 26 16:20:11 2006] [debug] mod_authnz_ldap.c(373): [client 192.168.1.98]
[3251] auth_ldap authenticate: using URL
ldap://ldap0.enthought/ou=People,dc=enthought?uid?sub
[Thu Oct 26 16:20:11 2006] [notice] child pid 3251 exit signal Segmentation
fault (11)


Version-Release number of selected component (if applicable):
httpd-2.2.2-1.2

How reproducible:
Always


Steps to Reproduce:
1. Setup a directory/location with mod_authnz_ldap authentication according to
http://httpd.apache.org/docs/2.2/mod/mod_authnz_ldap.html
2. Attempt to access that location in a web browser.
  
Actual results:
Authentication box. Then blank page.

Expected results:
Authentication box. Page at location.
Comment 1 Jeff Strunk 2006-10-26 17:34:17 EDT

*** This bug has been marked as a duplicate of 188073 ***

Note You need to log in before you can comment on or make changes to this bug.