Bug 2124830 - geo location not working: Anaconda didn't set default local locale
Summary: geo location not working: Anaconda didn't set default local locale
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Vladimír Slávik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F37FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-09-07 08:30 UTC by Jens Petersen
Modified: 2022-09-24 00:16 UTC (History)
10 users (show)

Fixed In Version: anaconda-37.12.5-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-24 00:16:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Jens Petersen 2022-09-07 08:30:56 UTC
Description of problem:
Geo location isn't working in F37 Anaconda for me:
always defaults to en_US (ie English (United States))

Version-Release number of selected component (if applicable):
anaconda-37.12.2-1.fc37

How reproducible:
100%

Steps to Reproduce:
1. boot F37 Live image outside USA
2. check detected default language locale

Actual results:
English (United States)

Expected results:
Geo location to work like for F36 (eg anaconda-36.16.5-2.fc36)

In my case it should be English (Singapore).

Comment 1 Kamil Páral 2022-09-07 11:20:04 UTC
The geo location doesn't seem to always kick in, but I just tested with Fedora-Workstation-Live-x86_64-37_Beta-1.5.iso and I was correctly detected to be in the Czech Republic.

Comment 2 Vladimír Slávik 2022-09-08 10:04:36 UTC
This is unfortunate, but not unexpected. Geolocation was recently modularized and we dropped some waiting, as it did not make any difference during initial testing. Looks like that does matter elsewhere :(

Comment 3 Vladimír Slávik 2022-09-09 13:29:39 UTC
This fixes the problem, enough for f37. https://github.com/rhinstaller/anaconda/pull/4328

For rawhide we'll want to refactor more which isn't needed in f37.

Comment 4 Adam Williamson 2022-09-09 22:40:06 UTC
Beta is signed off, so this can't go into it. Moving to proposed Final FE, though of course it can go in before the Final freeze with no FE status needed.

Comment 5 Fedora Update System 2022-09-19 17:18:32 UTC
FEDORA-2022-68907aa5e8 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-68907aa5e8

Comment 6 Geoffrey Marr 2022-09-19 18:19:39 UTC
Discussed during the 2022-09-19 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException (Final)" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-09-19/f37-blocker-review.2022-09-19-16.00.txt

Comment 7 Fedora Update System 2022-09-20 01:49:55 UTC
FEDORA-2022-68907aa5e8 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-68907aa5e8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-68907aa5e8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Jens Petersen 2022-09-23 06:00:25 UTC
Confirming this looks fixed indeed in anaconda-37.12.5-1.fc37

Thank you!

Comment 9 Fedora Update System 2022-09-24 00:16:05 UTC
FEDORA-2022-68907aa5e8 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.