Bug 212485 - some games from gnome-games package fail to run - unable to retrieve schema info
some games from gnome-games package fail to run - unable to retrieve schema info
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 18:23 EDT by Wade Nelson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 12:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum updates since initial bug report (676 bytes, text/plain)
2006-10-28 12:48 EDT, Wade Nelson
no flags Details

  None (edit)
Description Wade Nelson 2006-10-26 18:23:58 EDT
Description of problem:

On a fresh FC6 install, some gnome-games package games fail to run due to the
following error:

The default configuration values could not be retrieved correctly.

Please check your GConf configuration, specifically that the schemas have been
installed correctly.
Version-Release number of selected component (if applicable):


Affected games:
AisleRiot Solitaire (runs in very small window after displaying error)
Five or More (runs in same small window, same error)
FreeCell Solitaire (runs in same small window, same error)
Iagno (displays error, doesn't run at all)
Klotski (displays error, same small window)
Mahjongg (displays error, doesn't run at all)
Robots (small window, error)
SameGnome (small window, error)
TetraVex (small window, error)

Unaffected:
Attax
BlackJack
Four in a Row
Mines
Nibbles
Tali

schema files exist for all the games in /etc/gconf/schema

root@hb130 ~ $ ls -l /etc/gconf/schemas/iagno.schemas 
-rw-r--r-- 1 root root 2.6K Sep  4 23:40 /etc/gconf/schemas/iagno.schemas

could find nothing on any of the gnome games or any specific gnome game using
gconf-editor 'Find' function

This is a 'new' user, fresh FC6 install.
gnome-games was not installed during install despite "GNOME Desktop Environment"
being selected, was installed using yum post-install.

How reproducible:
100% consistent

Additional info:

root@hb130 ~ $ cat /etc/fedora-release 
Fedora Core release 6 (Zod)

root@hb130 ~ $ yum list installed '*gnome*game*'
Loading "installonlyn" plugin
Installed Packages
gnome-games.i386                         1:2.16.0-1.fc6         installed   
    
root@hb130 ~ $ uname -a
Linux hb130.fedora 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686
i686 i386 GNU/Linux
Comment 1 Wade Nelson 2006-10-28 12:47:27 EDT
This issue is resolved... After updates installed 2006.10.28 and a reboot,
gnome-games function properly.  A reboot alone wasn't the issue, since I've
shutdown/started my laptop several times since initial bug report.  Not sure
what exactly caused or fixed the issue, attached is yum.log containing updates
since installation of gnome-games as described in Comment 1.
Comment 2 Wade Nelson 2006-10-28 12:48:06 EDT
Created attachment 139643 [details]
yum updates since initial bug report

Note You need to log in before you can comment on or make changes to this bug.