Bug 21249 - devfsd fails when redhat 7.0 is updated with glibc 2.2
Summary: devfsd fails when redhat 7.0 is updated with glibc 2.2
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-22 16:09 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 17:44:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-22 16:09:19 UTC
Devfsd fails under Redhat 7.0 updates to glibc 2.2 because of more
stringent checking in the dynamic linking functions. This patch is
needed to restore functionality

diff -rNu devfsd-orig/devfsd.c devfsd/devfsd.c
--- devfsd-orig/devfsd.c        Mon Jul  3 21:43:07 2000
+++ devfsd/devfsd.c     Wed Nov 22 15:56:16 2000
@@ -1707,7 +1707,11 @@
        free (so);
        return (NULL);
     }
+#if __GLIBC__ == 2
+    if (strcmp (name, "GLOBAL") == 0) so->handle = RTLD_DEFAULT;
+#else
     if (strcmp (name, "GLOBAL") == 0) so->handle = RTLD_NEXT;
+#endif
     else if ( ( so->handle = dlopen (name, RTLD_NOW) ) == NULL )
     {
        free ( (char *) so->name );

Comment 1 Need Real Name 2001-03-03 00:48:50 UTC
This bug is fixed in devfsd 1.3.9.

Comment 2 Arjan van de Ven 2001-03-05 17:47:44 UTC
Fixed by using devfs 1.3.11


Note You need to log in before you can comment on or make changes to this bug.