Bug 212495 - Installer does not find existing installation to update when installation media is on root partition
Installer does not find existing installation to update when installation med...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2006-10-26 20:27 EDT by Joseph Teichman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 17:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Teichman 2006-10-26 20:27:41 EDT
Description of problem:
The installer is not finding the existing installation of Fedora when the
installation media is on the same partition as the root partition.

How reproducible:
always.

Steps to Reproduce:
1. Have a previous version of Fedora installed (I used Fedora 5)
2. Download the installation disks to a directory under the root partition
3. Burn the first disk to a CD for booting
4. Boot installation CD using "askmethod"
5. Select the correct drive and directory when selecting location of
installation media

  
Actual results:
When the installer searches for current installations of Fedora, nothing is
found and the installer move onto the partitioning options.

Expected results:
The installer should find the current installation and give the user the option
to upgrade.
Comment 1 Ben Liblit 2006-10-28 01:50:25 EDT
I'm seeing the same symptoms with a slightly different setup.  I used a bootable
USB key with "diskboot.img" rather than a burned CD.  Otherwise things are as in
the original reporter's description.  ISO images are stored in the same
partition as the root of the existing FC5 installation.  Anaconda does not find
this existing installation and does not offer to upgrade, but instead goes down
the new installation path.
Comment 2 John McNair 2006-12-16 16:15:59 EST
I just had a friend that had the same problem.  He had changed
/etc/redhat-release to indicate ES because some third party package thought that
was a requirement.  He switched back to the original FC5 redhat-release file,
and anaconda detected the installation as expected.  There's no guarantee that
this root cause is the same, but that's something that's easy to forget about
months later.
Comment 3 Chris Lumens 2007-03-12 15:55:33 EDT
Joseph - does your previous installation use reiserfs/xfs/jfs?  Can you check on
tty1, tty3, and tty4 and see if there are any obvious error messages?
Comment 4 Joseph Teichman 2007-03-14 21:22:31 EDT
I only used ext3. 
I have since upgraded the machine to FC6, so how can I check the other terminals
for errors now?
Comment 5 David Cantrell 2007-03-15 17:48:05 EDT
Closing as CANTFIX per comment #4.  For future reference, you cannot use the
same partition as the source and destination for installation purposes.  Your
source partition is marked as protected once you tell anaconda that's where the
source is.  You have to use an entirely different partition for the installation
destination.

Note You need to log in before you can comment on or make changes to this bug.