Bug 212519 - Data on DVD is unreadable with UDF - readable with ISO9660
Data on DVD is unreadable with UDF - readable with ISO9660
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 04:00 EDT by Ralf Ertzinger
Modified: 2008-04-27 00:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 00:59:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2006-10-27 04:00:48 EDT
Description of problem:
I have a data DVD which has both filesystems on it - UDF and ISO9660. Reading a
specific file while the DVD is mounted as UDF just results in a bunch of NUL
bytes. Reading the same file while the DVD is mounted as ISO9660 results in
usable data.

See:

$ sudo mount -t udf -o ro /dev/hdc /media/
$ mount | grep hdc
/dev/hdc on /media type udf (ro)
$ ls -l /media/gen/main_0.ark
-r-xr-xr-x 1 4294967295 4294967295 2773199404 Mar  8  2006 /media/gen/main_0.ark
$ dd if=/media/gen/main_0.ark bs=16 count=5 | hexdump -C
5+0 records in
5+0 records out
80 bytes (80 B) copied, 0.000100761 seconds, 794 kB/s
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00000050
$ sudo umount /media/
$ sudo mount -t iso9660 -o ro /dev/hdc /media/
$ mount | grep hdc
/dev/hdc on /media type iso9660 (ro)
$ ls -l /media/gen/main_0.ark
-r-xr-xr-x 1 root root 2773199404 Mar  8  2006 /media/gen/main_0.ark
$ dd if=/media/gen/main_0.ark bs=16 count=5 | hexdump -C
5+0 records in
5+0 records out
00000000  77 39 db 7a 47 59 d3 ea  c9 a9 3e 94 2c 72 13 7f  |w9.zGY....>.,r..|
00000010  4d b5 c4 bb f9 71 d1 32  57 fb 0f cc 4a a3 d0 4a  |M....q.2W...J..J|
00000020  f6 92 36 ab d7 1a 9d ca  1a 3e 97 46 d2 34 0b 21  |..6......>.F.4.!|
00000030  14 44 7e 14 41 02 2d 16  be 6e f3 a6 27 67 8f 46  |.D~.A.-..n..'g.F|
00000040  3e ba dc 3a 92 b4 41 e0  1a 24 06 03 61 1e e1 21  |>..:..A..$..a..!|
00000050
80 bytes (80 B) copied, 0.0666573 seconds, 1.2 kB/s

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
With this DVD always

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:
Unusable data when reading UDF

Expected results:
Usable data when reading UDF

Additional info:
Comment 1 Ralf Ertzinger 2006-10-27 07:02:37 EDT
Other files from the same DVD read fine with UDF and ISO9660, btw.
Comment 2 Chuck Ebbert 2007-04-27 16:56:08 EDT
This may be due to a 1GB size limitation in the UDF driver.
Comment 3 Eric Sandeen 2007-09-12 13:58:42 EDT
That 1GB file size limit should be lifted on latest kernels - is this still an
issue?

-Eric
Comment 4 Bug Zapper 2008-04-03 14:32:58 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.