Bug 212557 - Link libgtk-1.2 against libgdk
Link libgtk-1.2 against libgdk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk+ (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Patch, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 09:42 EDT by Rex Dieter
Modified: 2008-02-05 19:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 19:41:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
enable -no-undefined -Wl,--no-undefined when building shared libs (741 bytes, patch)
2006-10-27 09:42 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2006-10-27 09:42:47 EDT
Somewhere along the line, this bug that was fixed, become unfixed since patch30
(that fixes this) isn't applied anymore.

See also related thread
http://www.redhat.com/archives/fedora-devel-list/2006-October/msg00724.html
about how these missing symbols make linking fail in some situations (like what
using -Wl,--as-needed).

Attached also is a patch that enables 
-no-undefined -Wl,--no-undefined
when building shared libs to prevent something like this from happening again.


+++ This bug was initially created as a clone of Bug #106677 +++

The fact that libgtk doesn't link agains libgdk upsets prelink,
and we still have a lot of libgtk-1.2 binaries even in Cambridge.

It's probably worth adding this inter-library dependency to
gtk+ package.

-- Additional comment from otaylor@redhat.com on 2003-10-27 16:10 EST --
* Mon Oct 27 2003 Owen Taylor <otaylor@redhat.com> 1:1.2.10-28.1
- Cave like a cheap house of cards and add gdk-pixbuf dependency (#105613)
- Add gtkrc.*.utf8 RC files for CJK (#84593)
- Add a dependency on libgdk to libgtk (#106677)
Comment 1 Rex Dieter 2006-10-27 09:42:48 EDT
Created attachment 139579 [details]
enable -no-undefined -Wl,--no-undefined when building shared libs
Comment 2 Rex Dieter 2008-02-05 19:41:36 EST
This was fixed when I started to help maintain this.

Note You need to log in before you can comment on or make changes to this bug.