Bug 212577 - USB-Serial dongle not detected
USB-Serial dongle not detected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
All Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
http://cups.org/str.php?L2061
: Reopened
Depends On:
Blocks: FC6Update 212580
  Show dependency treegraph
 
Reported: 2006-10-27 11:43 EDT by Harish Pillay
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.7-1.3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 07:47:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harish Pillay 2006-10-27 11:43:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):

FC6 Gold, Cups

How reproducible:

Steps to Reproduce:
1. Plug into USB port a USB<->Serial dongle
2. It appears as /dev/ttyUSB0 (if it was the 1st one)
3. Plug in a Serial printer to dongle
  
Actual results:
Trying to set up the printer via Printers menu item does
not show up USB port nor USB/Serial.  

Expected results:

Printers should have given the option to add a printer on
a port /dev/ttyUSB0 manually.  That would have solved the
problem.

What remains is how to set the speed of the serial link
via a USB port.

Additional info:
Comment 1 Tim Waugh 2006-10-27 11:54:43 EDT
For reference: cups-1.2.4-9

Upstream bug report with patch:
  http://cups.org/str.php?L2061
Comment 2 Fedora Update System 2006-11-07 17:25:09 EST
Fixed in update: cups-1.2.5-2.fc6.8
Comment 3 Harish Pillay 2006-11-20 11:36:44 EST
Just tested and this time the USB-Serial dongle was detected correctly as
/dev/ttyUSB0.  I was able to set up the printer.

The printer is a Zebra Cameo 3 label printer and it expects the serial port to
be 19200, 8N1 with Xon/Xoff/Hardware and DSR=0.  I tried all the options in the
system-config-printer GUI.  When the printer options are changed around, and the
check box "Enabled" under the Settings tab is checed ON, then the lpq says that
the printer is ready.  The GUI says that it is idle.  Sending out a test page -
nothing happens.  lpq shows it in the queue.  When the test page was sent, the
lpq status showed that it was ready and printing and then goes into a "zebra is
not ready" state.

Removing the queue entry with lprm queue#, the lpq still returns the state the
the "zebra is not ready".

Now restarting the GUI, I notice that the printer (under Settings tab) show the
"Enabled" check box unchecked.  Not sure why that happens for I had checked it
before exiting the GUI.

I tried with minicom and connected to /dev/ttyUSB0 directly (with 192008N1) and
I was able to echo characters on the printer.

What else can I try?
Comment 4 Tim Waugh 2006-11-20 13:35:00 EST
Does /var/log/cups/error_log show why the job failed?
Comment 5 Harish Pillay 2006-11-21 07:16:45 EST
Yes, it does.  Apologies for not checking that.  It said that there was no
permission to write to /dev/ttyUSB0.

The default ownership and rw status when the dongle is plugged in is: 
crw-rw---- 1 root uucp 188, 0 Nov 21 20:00 /dev/ttyUSB0

I had to change the rw to:
crw-rw-rw- 1 root uucp 188, 0 Nov 21 20:00 /dev/ttyUSB0

before the printing was successful. 

Not sure where I need to set up the right permissions to kick in when the USB
dongle is plugged in.

Thanks for the tip.
Comment 6 Tim Waugh 2006-11-21 09:16:31 EST
cups-1.2.7-1.2.fc6 from updates-testing should fix it.  It makes the serial
backend run as root.  It doesn't seem to have been pushed yet, but will be in
the next couple of days I expect.

Note You need to log in before you can comment on or make changes to this bug.