Bug 2125784 - kernel-5.19.8 fails to boot on x64 with amd renoir GPU.
Summary: kernel-5.19.8 fails to boot on x64 with amd renoir GPU.
Keywords:
Status: CLOSED DUPLICATE of bug 2125536
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 36
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-10 10:45 UTC by lmouillart
Modified: 2022-09-12 15:26 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-12 15:26:56 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
dmesg with gpu hang (279.45 KB, text/plain)
2022-09-10 10:45 UTC, lmouillart
no flags Details

Description lmouillart 2022-09-10 10:45:02 UTC
Created attachment 1910935 [details]
dmesg with gpu hang

1. Please describe the problem:
kernel-5.19.8-200.fc36.x86_64 fails to boot. It hangs during the boot process on my n Lenovo Yoga Slim 7 Pro 14ACH5, CPU AMD Ryzen 9 5900hx, GPU AMD Renoir, Wifi Mediatek mt7921e 


2. What is the Version-Release number of the kernel:
kernel-5.19.8-200.fc36.x86_64 


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
It work fine on any previous kernel release
First kernel with this issue : kernel-5.19.7-200.fc36.x86_64


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
- Install kernel-5.19.8-200.fc36.x86_64 on AMD Ryzen with GPU AMD Renoir
- Reboot
- During first the initialization phase of the GPU, the system hang

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
has not been tested.

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

Comment 1 Ralf Corsepius 2022-09-11 05:31:22 UTC
Did you try what is outlined in 
https://bugzilla.redhat.com/show_bug.cgi?id=2125536
esp. in 
https://bugzilla.redhat.com/show_bug.cgi?id=2125536#c3

Comment 2 lmouillart 2022-09-11 08:14:12 UTC
Thanks I downgraded linux-firmware, and indeed now it boots correctly with kernel 5.19.8.
On the other hand on https://bugzilla.redhat.com/show_bug.cgi?id=2125536 it did not work for them with 5.19.7, on my laptop it worked well with 5.19.7.

Comment 3 lmouillart 2022-09-12 15:26:56 UTC
As explained in https://bugzilla.redhat.com/show_bug.cgi?id=2125536#c15 I removed install_weak_deps=False in dnf.conf and made an update, and it works.
So it's the same causes as https://bugzilla.redhat.com/show_bug.cgi?id=21257842125536

*** This bug has been marked as a duplicate of bug 2125536 ***


Note You need to log in before you can comment on or make changes to this bug.