Bug 212657 - auto-whitelist: open of auto-whitelist file failed
auto-whitelist: open of auto-whitelist file failed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mimedefang (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 17:08 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-08 17:39:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-10-27 17:08:55 EDT
Description of problem:
When mimedefang is started during system boot, I find the following messages in 
my maillog. After restarting mimedefang manually, everything works for me:

Oct 26 16:06:30 tux mimedefang-multiplexor[2093]: Slave 1 stderr: auto-
whitelist: open of auto-whitelist file failed: locker: safe_lock: cannot create 
tmp lockfile //.spamassassin/auto-whitelist.lock.tux.17594 for //.spamassassin/
auto-whitelist.lock: No such file or directory

Somebody an idea how to fix this?

Version-Release number of selected component (if applicable):
mimedefang-2.57-5

How reproducible:
Everytime, see above.

Actual results:
Error messages when mimedefang is started up during booting time.

Expected results:
No error messages.
Comment 2 Robert Scheck 2006-10-31 16:17:58 EST
I sent a small patch upstream which will be applied to 2.58 when it gets 
released. As nobody else using this package reported the problem to me, I'll
try to wait for the update for now.
Comment 3 Robert Scheck 2006-11-08 16:58:38 EST
2006-11-07  David F. Skoll  <dfs@roaringpenguin.com>

        *  VERSION 2.58 RELEASED

[...]

        *  Sample init script sets HOME=/var/spool/MIMEDefang.
Comment 4 Robert Scheck 2006-11-08 17:39:55 EST
Fixed in 2.58-1 which should appear in the repositories soon.

21229 (mimedefang): Build on target fedora-development-extras succeeded.
21230 (mimedefang): Build on target fedora-6-extras succeeded.
21231 (mimedefang): Build on target fedora-5-extras succeeded.

Note You need to log in before you can comment on or make changes to this bug.