Bug 212676 - starting xorg corrupts console font on Apple Powerbook 12" (GeForce FX 5200)
starting xorg corrupts console font on Apple Powerbook 12" (GeForce FX 5200)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 18:44 EDT by Alex Kanavin
Modified: 2009-01-09 01:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 01:59:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (46.99 KB, text/plain)
2006-10-27 18:44 EDT, Alex Kanavin
no flags Details
xorg.conf file (627 bytes, text/plain)
2006-12-28 21:57 EST, Alex Kanavin
no flags Details
Xorg log when there is no xorg.conf file (18.60 KB, text/plain)
2006-12-28 22:12 EST, Alex Kanavin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12933 None None None Never

  None (edit)
Description Alex Kanavin 2006-10-27 18:44:02 EDT
Description of problem:
on my powerbook 12" with GeForce FX 5200 starting xorg corrupts console so that
it's totally unreadable.

How reproducible:
Always on FC6, also in installer.

Steps to Reproduce:
1. Boot into graphical login prompt
2. Press ctrl-alt-f1 to switch into console
Comment 1 Alex Kanavin 2006-10-27 18:44:12 EDT
Created attachment 139621 [details]
xorg log file
Comment 2 Alex Kanavin 2006-10-29 17:08:45 EST
Also, in FC6t3 booting the install CD and then switching to console seemed to work fine.
Comment 3 Alex Kanavin 2006-11-02 06:02:43 EST
I just tried FC5 install CD, and it corrupts the console too. It was probably some external condition that 
made FC6t3 work ok, but I can't think of anything.
Comment 4 Alex Kanavin 2006-11-15 12:14:44 EST
Apparently the nv driver gets very confused when there is more than one output
to use. Everything is fine when I'm using the laptop's built-in LCD only, but
when I plug in an external one, numerous troubles occur - the above font
corruption is one of them. I probably should report this to whoever's in charge
of nv, any pointers?
Comment 5 Matěj Cepl 2006-12-28 08:16:24 EST
Hi, Alex,

yes, you have reported your problem to the correct people, and I am sorry, that
we are replying to your report only now. Unfortunately, we could use very much
some more information about your setup. Could you, please, attach your X server
config file (/etc/X11/xorg.conf) to the bug report as individual uncompressed
file attachment using the bugzilla file attachment link below?

I would be also concerned about configuration from your previous installation.
Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Alex Kanavin 2006-12-28 21:57:15 EST
Created attachment 144518 [details]
xorg.conf file
Comment 7 Alex Kanavin 2006-12-28 22:12:39 EST
Created attachment 144519 [details]
Xorg log when there is no xorg.conf file

When I remove the xorg.cong, X Window doesn't start anymore. I have attached
the log file for this case. It makes a few attempts and then suggests I run the
configuration tool.
Comment 8 Alex Kanavin 2006-12-28 22:13:34 EST
There you go. Let me know if anything else is needed.
Comment 9 Alex Kanavin 2007-12-07 20:17:37 EST
Looks like the problem only happens when openfirmeware framebuffer driver is used. I have reported it 
upstream via freedesktop bugzilla to opensource nvidia driver people.
Comment 10 Matěj Cepl 2007-12-10 04:22:37 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 11 Alex Kanavin 2007-12-12 20:42:51 EST
Yes, the problem persists on Fedora 8. The freedesktop bug I have filed is here:
https://bugs.freedesktop.org/show_bug.cgi?id=12933
Comment 12 Bug Zapper 2008-11-26 02:03:10 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-01-09 01:59:31 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.