Bug 212700 (CVE-2006-5601) - CVE-2006-5601: xsupplicant < 1.2.8 (?) stack smashing vulnerability
Summary: CVE-2006-5601: xsupplicant < 1.2.8 (?) stack smashing vulnerability
Status: CLOSED RAWHIDE
Alias: CVE-2006-5601
Product: Fedora
Classification: Fedora
Component: xsupplicant
Version: 6
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL: http://nvd.nist.gov/nvd.cfm?cvename=C...
Whiteboard:
Keywords: Security
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-28 06:47 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-11-21 16:03:38 UTC


Attachments (Terms of Use)

Description Ville Skyttä 2006-10-28 06:47:18 UTC
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2006-5601
http://open1x.sourceforge.net/

"7 Oct 2006 -- Xsupplicant 1.2.8 is now available for download. This release 
has several bug fixes in it, including a fix to a stack smash that could 
potentially lead to a remote root exploit."

Seems to affect all FE versions.

Comment 1 Ville Skyttä 2006-11-12 09:36:27 UTC
ping?

Comment 2 Jan ONDREJ 2006-11-21 09:25:38 UTC
It is not possible to connect with xsupplicant 1.2.7, but works fine with
version 1.2.8. Please can somebody rebuild this package? Thank you.

You can found a new (working) rpm package at:
  http://ftp.upjs.sk/pub/users/SAL/Fedora/SRPMS/6/xsupplicant-1.2.8-0.src.rpm

Release version is changed by me to automatically update after fedora extras
release.

Comment 3 Tom "spot" Callaway 2006-11-21 16:03:20 UTC
FE4, FE5, FE6 all bumped to 1.2.8. Thanks for the new SRPM Jan. :)


Note You need to log in before you can comment on or make changes to this bug.