Bug 212706 - G965 locks when the xv extension is used
G965 locks when the xv extension is used
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2006-10-28 03:48 EDT by Noa Resare
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-21 12:55:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
logfile from wen the error is provoked (65.53 KB, application/octet-stream)
2006-10-28 03:48 EDT, Noa Resare
no flags Details
artifacts (612.72 KB, image/png)
2006-10-28 10:12 EDT, filippo david
no flags Details

  None (edit)
Description Noa Resare 2006-10-28 03:48:04 EDT
Description of problem:

Some programs lock up my X. To get any graphics at all I need to reboot. When
the program starts, the screen freezes for a moment, the colormap gets weird,
then x restarts. Then it seems like X tries to start again for a few times. The
upper part of the screen works but the lower part is garbled. The mouse pointer
works in the fractions of a second before x craches into blackness.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run 'totem SOME_AUDIO_FILE'
Actual results:
the lockup described above

Expected results:
perhaps totem tries to do some visualization or somesuch

Additional info:
I've tried updating the i810 driver to 1.7.2 but it didn't change anything.

The first thing that happens is that the lower part of the screen goes crazy.
Perhaps this is the result of the video card not allocating enough memory.

My Hardware: 
An ASUS P5B-VM motherboard with integrated i965 graphics and 2GiB of DDR2
memory. Screen resolution is 1600x1200
Comment 1 Noa Resare 2006-10-28 03:48:04 EDT
Created attachment 139628 [details]
logfile from wen the error is provoked
Comment 2 filippo david 2006-10-28 04:24:22 EDT
I have the same problem. Whenever i start an application using Xv ( totem, xine,
mplayer ). With mplayer if i switch to another driver (x11, gl, gl2) it works.
Even totem works switching to the x11 driver in gstreamer-properties.

I'm running a FC6 with latest updates on an Intel DG965WH motherboard with
integrated i965 graphics.

To me it seems the same as this bug:

Comment 3 Noa Resare 2006-10-28 08:49:29 EDT
Thanks for the reference. I have now verified that the patch in
https://bugs.freedesktop.org/show_bug.cgi?id=8594 solves the problem.

I have prepared updated srpm and x86_64 rpm packages if someone is in a hurry
getting a fix for this problem. The package is updated to the latest upstream
release (1.7.2) + the patch referenced above. It can be found at
Comment 4 filippo david 2006-10-28 10:12:14 EDT
Created attachment 139636 [details]
Comment 5 filippo david 2006-10-28 10:16:07 EDT
Comment on attachment 139636 [details]

now it works perfectly with metacity, but with desktop effects enabled i get
this kind of artifacts, it's the same even with gl gl2 drivers.
Comment 6 Noa Resare 2006-11-01 03:15:11 EST
Filipo, I think the issue you're trying to describe is separate from the issue
I'm reporting here. Feel free to open a separate bug report detailing your issue.

The patch is now added to the upstream git tree and it is reasonable to expect
that the fix will be included in the upcoming 1.7.3 release.
Comment 7 filippo david 2006-11-10 08:04:26 EST
I just tried the latest version in updates-testing:


and Xv works, i still get artifacts with compiz, but Xv does not lock the
machine anymore.
Comment 8 Noa Resare 2006-11-21 12:55:06 EST
Since xorg-x11-drv-i810-1.6.5-10.fc6 was released as an offical update yesterday
and I have verified that this does indeed fix the problem I'm closing this now.
Thanks to ajackson@redhat.com for backporting the patch.

Note You need to log in before you can comment on or make changes to this bug.