Bug 212717 - can't print to smb share on Windows
can't print to smb share on Windows
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-10-28 05:25 EDT by David Bobroff
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 07:18:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cups error log per request. (10.54 KB, application/octet-stream)
2006-11-02 07:39 EST, David Bobroff
no flags Details
Cups error log per request. (22.49 KB, application/octet-stream)
2006-11-02 07:40 EST, David Bobroff
no flags Details

  None (edit)
Description David Bobroff 2006-10-28 05:25:15 EDT
Description of problem:
First, it is not possible to browse to the shared printer on my LAN.  The two
workgroups are displayed, but no shared printer.  In the field at the top of the
form I can enter the location following the 'smb://'
<machine-name>/<printer-name> and then I enter 'guest' in the username field. 
When I click 'verify' it then tells me that the share is accessible.  I cannot,
however, print.


Version-Release number of selected component (if applicable):

0.7.32



How reproducible:

Attempt to set up printing on a Samba share printer on a Windows machine.

Steps to Reproduce:
1. System --> Administration --> Printing
2. Click 'New Printer,' enter printer info and click 'Forward .'
3. Click 'Windows Printer via SAMBA'
4. Workgroups appear listed under share. (no further browsing available)
5. Enter 'MACHINE-NAME/PRINTER-NAME' in field at top of dialog box.
6. Enter 'GUEST' in Username box.
7. Click 'verify' (in my case this shows share accessibility)
8. Click 'Forward' and select printer make/model. (This works fine)
9. Be sure printer is enabled etc. and try a test page.

Actual results:

Nothing.  Printer does not respond.  Running 'lpq' shows the print job queued.

Expected results:

Printer spits out test page and I happily go on with printing.

Additional info:

Hardware:
IBM ThinkPad T30 256Mb RAM

I've been using RH Linux versions since RH5.  In the later RH distros prior to
Fedora I found in RH7-8-9 that printing via Samba was fairly easy to make work.
 I could browse to the printer in the printer configuration program and all was
well.  More recently I was using FC3 for some time.  The printing configuration
had changed.  I recall that I could not browse to my printer but it was fairly
strightforward to specify my printer by entering the information in the dialog
box form.  Then it Just Worked.  Same with FC5 (I skipped FC4).  I even tried
reinstallinrg FC5, got printing set up and then installed FC6 again using
'upgrade' rather than 'clean install' to see if Samba printing would survive. 
It did not.
Comment 1 Tim Waugh 2006-11-02 07:26:09 EST
Please attach /var/log/cups/error_log.  Thanks.
Comment 2 David Bobroff 2006-11-02 07:39:55 EST
Created attachment 140117 [details]
Cups error log per request.
Comment 3 David Bobroff 2006-11-02 07:40:12 EST
Created attachment 140118 [details]
Cups error log per request.
Comment 4 Tim Waugh 2006-11-02 08:25:56 EST
E [30/Oct/2006:06:52:47 +0000] Unable to find IP address for server name "dhcppc
1"!

Some problem with your network perhaps?
Comment 5 Tim Waugh 2006-11-13 11:49:01 EST
*ping*
Comment 6 Tim Waugh 2006-11-22 07:18:58 EST
No feedback; closing.  Please re-open if you see this problem again.

Note You need to log in before you can comment on or make changes to this bug.