Bug 212721 - Trying to add local zone files problematic
Trying to add local zone files problematic
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 07:39 EDT by Mike Cohler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 10:03:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Cohler 2006-10-28 07:39:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: Every time


Steps to Reproduce:
1. Since there is no pre-existing named.conf file run system-config-bind
2. A default named.conf file is created
3. Now named cannot be stopped or its status seen with service named ststus
4) The workaround is to re-boot !
  
Actual results:named gets hung


Expected results:named should not get hung


Additional info:After re-booting named is running if chkconfig named on has been
executed.  In fact I wanted to add local zone files and this was the only way to
do it - i.e. let system-config-bind create a default file, then edit to add the
additional zone into, and then reboot - now the system works and local name
resolution works fine.
Comment 1 Martin Stransky 2006-12-06 08:49:39 EST
Hm, it's quite strange and I can't reproduce it. Do you have any log? Like
messages from /etc/messages? Do you use caching-nameserver or bind-chroot package?
Comment 2 Mike Cohler 2006-12-06 09:02:54 EST
This goes back quite a way now so I doubt if there is any log file with relevant
entries left in - at the time (immediately after I installed (clean) fc6), I
tried immediately to look at /var/named/chroot/etc/, and at that stage
named.conf did not exist.  

I also note that on October 31st bind was updated via yum, so it is possible
that with an updated system the error no longer exists.  However if someone
still has a freshly installed version of fc6 but has not yet updated bind I
would wager that the problem would certainly exist in that system before it is
updated. I remember discussing this on one of the lists and other users posted
to confirm the problem. (I have just checked back in fedora list and the posting
was at http://marc.theaimsgroup.com/?l=fedora-list&m=116375199216712&w=2 )
 
Also at that time I think caching-nameserver was installed by default in my system.

The sequence of events is that once I found the problem, then I ran
system-config-bind which generated in initial set of files with a standard
named.conf and then I changed the file for my needs.  Then restarted named, and
also did yum remove caching-nameserver.

Now on all my machines I have removed caching nameserver, and only have named
(bind) running sweetly.   
Comment 3 Martin Stransky 2006-12-06 10:03:26 EST
okay, so reopen it please if you have any extra hints...

Note You need to log in before you can comment on or make changes to this bug.