Bug 212726 - Kernel does not poweroff my laptop (Toshiba A105-S361)
Kernel does not poweroff my laptop (Toshiba A105-S361)
Status: CLOSED DUPLICATE of bug 203930
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 09:40 EDT by Ahmed Kamal
Modified: 2007-12-30 22:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-30 22:40:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ahmed Kamal 2006-10-28 09:40:24 EDT
Description of problem:
When I shutdown my laptop, the shutdown sequence works fine, and at the end, the
screen just goes blank (but still lit), and my laptop is still on! I have to
press the power switch for 4 seconds to force it off. This is super irritating
for me because I can't leave it on at night and schedule a poweroff!

Version-Release number of selected component (if applicable):
2.6.18-1.2798.fc6

How reproducible:
On rare occasions, the problem doesn't appear, especially if the uptime is very
low! But 95% of the time, it doesn't poweroff.

Steps to Reproduce:
1. Shutdown the laptop using 'poweroff' or from the menu
2. Watch services powerdown ok
3. The power switch does poweroff

Additional info:
I have faced the same issue with ubuntu dapper and edgy. Only Suse 10.1 is able
to correctly poweroff my laptop every time!
I have used many workarounds (from ubuntu bug reports) such as reboot=h,
apm=poweroff apm=realmode_off, but none of them seem to work
Comment 1 Gérard Milmeister 2006-11-02 16:23:51 EST
I have a similar problem on a desktop system. FC5 used to power off as it
should, but on FC6, shutdown proceeds as expected, and even seems to power off
the disks. However the screen stays on with the last messages from the shutdown
sequence displayed.
Comment 2 Adam Pribyl 2006-11-04 15:16:44 EST
Same here. Desktop with VIA cpu and board with:
00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)

I tried different acpi=on apm=off etc. but nothing workds. Moreover kernel
refuses to use apci with message that I have to use acpi=force, but adding
acpi=force to kernel boot parametr does nothing.
Comment 3 Adam Pribyl 2006-11-05 07:18:05 EST
So I was too fast to judge acpi=force. The kernel produces the message
ACPI: BIOS age (1997) fails cutoff (1999), acpi=force is required to enable ACPI
ACPI: acpi=force override
but acpi is forced and it solves for me this issue. This was not needed with FC5.
Comment 4 Ahmed Kamal 2006-12-07 18:25:35 EST
WORKAROUND FOUND:
================
It turns out kernel wasnt powering off on my hardware because of the module
"snd_hda_intel"
I added "rmmod snd_hda_intel" is the shutdown scripts, and now it has been
powering off correctly for 15 days
Comment 5 Leszek Matok 2007-05-20 07:35:38 EDT
Isn't this a duplicate of bug #203930, then?
Comment 6 Jon Stanley 2007-12-30 22:40:18 EST

*** This bug has been marked as a duplicate of 203930 ***

Note You need to log in before you can comment on or make changes to this bug.