Bug 212753 - Synaptics touchpad parameters should be set sanely and changable on the fly
Summary: Synaptics touchpad parameters should be set sanely and changable on the fly
Status: CLOSED DUPLICATE of bug 215157
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-28 18:45 UTC by Per Bjornsson
Modified: 2018-04-11 15:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 23:30:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add the "SHMConfig" option to the defaults for Synaptics touchpads (561 bytes, patch)
2006-10-29 21:10 UTC, Per Bjornsson
no flags Details | Diff

Description Per Bjornsson 2006-10-28 18:45:35 UTC
Description of problem:
The Synaptics driver supports runtime configuration changes if the parameter
Option "SHMConfig" "yes"
is set in the InputDevice section of xorg.conf for that driver; there was no
such setting in my xorg.conf after running system-config-display --reconfig.
After setting that parameter, users can use e.g. gsynaptics to configure their
touchpads to their liking. Unfortunately this is not done by
system-config-display, so the per-user configuration utilities are completely
useless by default. (The manpage for synaptics does warn that turning this on
lets any local user change touchpad parameters, is this the reason why the
feature is not turned on?)

The defaults might need some work too. Perhaps e.g. the side scrolling should
also be turned off by default:
Option "HorizScrollDelta" "0"
since that seems to be the most potentially confusing behavior, and it interacts
pretty badly with firefox - it's really easy to skip back and forth by mistake
(cf. e.g. bug #187412).

Version-Release number of selected component (if applicable):
system-config-display-1.0.45-1 (fc6)

How reproducible:
Always

Comment 1 Per Bjornsson 2006-10-29 21:10:36 UTC
Created attachment 139679 [details]
Add the "SHMConfig" option to the defaults for Synaptics touchpads

Patch to default-enable configuration of Synaptics touchpads using e.g.
gsynaptics.

Comment 2 Per Bjornsson 2006-10-29 21:12:13 UTC
Changing component to rhpxl, since that's where the actual settings for the
touchpad are handled.

Comment 3 Matěj Cepl 2007-12-13 23:30:36 UTC

*** This bug has been marked as a duplicate of 215157 ***


Note You need to log in before you can comment on or make changes to this bug.