Bug 212782 - wine versions newer than 0.9.22 don't work
wine versions newer than 0.9.22 don't work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
5
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-28 22:07 EDT by Alex W. Jackson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 19:12:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -ff outputs (99.09 KB, application/x-gzip)
2006-10-28 22:07 EDT, Alex W. Jackson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 1182 None None None Never

  None (edit)
Description Alex W. Jackson 2006-10-28 22:07:38 EDT
Description of problem:
The last Wine version that worked for me was 0.9.22 (which has just been removed
from the main Extras repository).  0.9.23 and 0.9.24 hang forever when I attempt
to run any application, including builtin applications like winecfg.

Version-Release number of selected component (if applicable):
wine-core-0.9.23-1.fc5
wine-core-0.9.24-1.fc5

How reproducible:
Run winecfg, or any of the other builtin Wine apps, or any actual Windows executable
  
Actual results:
The application gets as far as displaying an empty window (just a titlebar and
frame) and then hangs

Expected results:
Application starts normally

Additional info:
Attached are strace -ff outputs from wine 0.9.22 (which works) and 0.9.23 (which
hangs)  I hope these are useful in determining where the hang occurs
Comment 1 Alex W. Jackson 2006-10-28 22:07:38 EDT
Created attachment 139655 [details]
strace -ff outputs
Comment 2 Andreas Bierfert 2006-10-29 02:24:50 EST
Could you please check which wine packages you have installed and if not install
the wine meta package so you are not missing anything important. After that
please go to your home directory and mave the ~/.wine folder somewhere else and
make a fresh start with wineprefixcreate and try this again.
Comment 3 Alex W. Jackson 2006-10-29 03:19:15 EST
I have the wine metapackage and all its dependencies installed.  Deleting and
recreating ~/.wine/ makes no difference.
Comment 4 Eddy Zhao 2006-10-30 05:38:33 EST
Have the same problem on fc6 with wine 0.9.23.
Someone find kill all scim related processes and then start winecfg could 
circumvent the problem.

Comment 5 Alex W. Jackson 2006-10-30 08:31:48 EST
I can confirm that.  If I disable SCIM (rename ~/.xinput.d/, log out, log back
in) then Wine starts normally.
Comment 6 James Arendt 2006-10-31 18:21:32 EST
I have also had the same problem since Wine 0.9.23. I live in Japan and need 
SCIM for Japanese language input. Wine was working fine in it up to version
0.9.22. After that Wine hangs. However if I disable SCIM log out and then back
in again, Wine works fine. I am now using Wine version 0.9.24.
Comment 7 Andreas Bierfert 2006-11-03 19:12:46 EST
This is cause by a bug in x... see external bugzilla references and recent posts
on the wine list about it... closing as upstream.
Comment 8 Eddy Zhao 2006-11-03 21:52:58 EST
Hi Andreas, could you post the "external bugzilla references and recent posts
on the wine list" link here? So, I could apply the patch. Thanks.
Comment 9 Andreas Bierfert 2006-11-04 03:50:12 EST
Just look below the posts =) There you can find that it is bug #1182 @
freedesktop.org.

Note You need to log in before you can comment on or make changes to this bug.