Bug 2127841 - F36->37 upgrade fails: Transaction test error: file /usr/bin/WebKitWebDriver from install of webkit2gtk4.1-2.38.0-1.fc37.x86_64 conflicts with file from package webkit2gtk3-2.38.0-2.fc36.x86_64
Summary: F36->37 upgrade fails: Transaction test error: file /usr/bin/WebKitWebDriver...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk
Version: 37
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-19 08:29 UTC by Milan Zink
Modified: 2022-09-24 00:16 UTC (History)
5 users (show)

Fixed In Version: webkitgtk-2.38.0-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-24 00:16:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Milan Zink 2022-09-19 08:29:51 UTC
Description of problem:
Error: Transaction test error:
  file /usr/bin/WebKitWebDriver from install of webkit2gtk4.1-2.38.0-1.fc37.x86_64 conflicts with file from package webkit2gtk3-2.38.0-2.fc36.x86_64
  file /usr/bin/WebKitWebDriver from install of webkit2gtk5.0-2.38.0-1.fc37.x86_64 conflicts with file from package webkit2gtk3-2.38.0-2.fc36.x86_64


Version-Release number of selected component (if applicable):


How reproducible:
sudo dnf upgrade --refresh
sudo dnf install dnf-plugin-system-upgrade
sudo dnf system-upgrade download --refresh --releasever=37

Steps to Reproduce:
sudo dnf upgrade --refresh
sudo dnf install dnf-plugin-system-upgrade
sudo dnf system-upgrade download --refresh --releasever=37

Actual results:
Error: Transaction test error:
  file /usr/bin/WebKitWebDriver from install of webkit2gtk4.1-2.38.0-1.fc37.x86_64 conflicts with file from package webkit2gtk3-2.38.0-2.fc36.x86_64
  file /usr/bin/WebKitWebDriver from install of webkit2gtk5.0-2.38.0-1.fc37.x86_64 conflicts with file from package webkit2gtk3-2.38.0-2.fc36.x86_64

Expected results:
Upgrade works / Transaction test == ok

Comment 1 Michael Catanzaro 2022-09-19 14:02:58 UTC
Oh no, that needs to be removed from webkit2gtk5.0 for now. I will fix that.

It's still going to conflict with webkit2gtk4.1, but that's expected. You should be automatically upgraded from webkit2gtk -> webkit2gtk4.0, which doesn't have the /usr/bin/WebKitWebDriver. Not sure why that wouldn't be happening.

Comment 2 Milan Zink 2022-09-19 18:29:25 UTC
Ok, thx for quick reply. Let me know when I can re-test.

Comment 3 Michael Catanzaro 2022-09-20 12:56:00 UTC
(In reply to Milan Zink from comment #2)
> Ok, thx for quick reply. Let me know when I can re-test.

Sadly you might need to be patient. s390x and aarch64 are both still building after 22 hours.

Comment 4 Milan Zink 2022-09-20 13:06:38 UTC
ok, np. 

I assume it's this build - https://koji.fedoraproject.org/koji/buildinfo?buildID=2064689

Comment 5 Fedora Update System 2022-09-20 18:18:07 UTC
FEDORA-2022-0c00617967 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-0c00617967

Comment 6 Fedora Update System 2022-09-21 02:34:27 UTC
FEDORA-2022-0c00617967 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-0c00617967`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-0c00617967

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Milan Zink 2022-09-21 06:43:25 UTC
Hi Michael,

I can confirm that upgrade works with the latest build. Thank you

Transaction check == ok. New package replaces old one. All good.

Cheerr
Milan

```
cat /etc/redhat-release 
Fedora release 37 (Thirty Seven)
```

Comment 8 Fedora Update System 2022-09-24 00:16:19 UTC
FEDORA-2022-0c00617967 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.