Bug 212801 - Stale NFS mount
Stale NFS mount
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 02:00 EST by Alex Mondshain
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-09 13:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Mondshain 2006-10-29 02:00:42 EST
Description of problem:

NFS connection becomes stale after appr. one hour 

Version-Release number of selected component (if applicable):

NFS client FC6 
Linux alex 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:54:20 EDT 2006 i686 i686 i386
GNU/Linux
server FC5 2.6.16-1.2111_FC5
How reproducible:
always 

Steps to Reproduce:
1.server (FC5), /etc/exports,  /storage/d4     192.168.100.*(rw,sync)
2.client (FC6), /etc/fstab
192.168.100.1:/storage/d4     /storage/d4    nfs   
rsize=8192,wsize=8192,timeo=14,soft
3.mount -a 
4.wait for 1hr 
  cd d4
-bash: cd: d4 Stale NFS file handle

Actual results:


Expected results:

Additional info:

Connection to same exports works from FC2,FC4,FC5 
Connection backomes staile using exports from other servers , FC2, FC4 

Thanks 
Alex M
Comment 1 Steve Dickson 2006-10-31 19:08:54 EST
Would it be possible to post a bzip2 binary tethereal network trace?
Something similar to:

    tethereal -w /tmp/data.pcap host <server> ; bzip2 /tmp/data.pcap

Comment 2 Alex Mondshain 2006-11-01 01:03:08 EST
Hi


By a pure coincidence i found a fix for a becoming stale connection

The solution for me is to declare export with a real ip of the server

/storage/d4     192.168.100.*(rw,sync)
/storage/d4     192.168.100.220(rw,sync)

After adding the line 220 ip address , the mount staying in place

Is this of any help , do you still need a dump ?

Alex M
Comment 3 Steve Dickson 2006-11-01 08:24:01 EST
Yes.. if you would mind taking the time... 

It appears this could be a DNS issue, so having a 
trace will hopefully prove that theory...  
Comment 4 Steve Dickson 2007-03-09 13:56:47 EST
Closing as not a bug since there seem to be a solution... 

Note You need to log in before you can comment on or make changes to this bug.