This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 212810 - system-config-display crashes during startup
system-config-display crashes during startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 04:09 EST by Vaclav "sHINOBI" Misek
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 17:36:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vaclav "sHINOBI" Misek 2006-10-29 04:09:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
Crash during startup.

Version-Release number of selected component (if applicable):
system-config-display-1.0.45-1

How reproducible:
Always


Steps to Reproduce:
1.start system-config-display from shell
2.
3.

Actual Results:
# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 311, in ?
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib64/python2.4/site-packages/rhpxl/xhwstate.py", line 177, in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib64/python2.4/site-packages/rhpxl/xhwstate.py", line 296, in init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib64/python2.4/site-packages/rhpxl/xhwstate.py", line 60, in compare_resolution
    (w1, h1) = resolution_from_string(res1)
  File "/usr/lib64/python2.4/site-packages/rhpxl/xhwstate.py", line 50, in resolution_from_string
    return (string.atoi(w), string.atoi(h))
  File "/usr/lib64/python2.4/string.py", line 403, in atoi
    return _int(s, base)
ValueError: invalid literal for int(): 864_85

Expected Results:


Additional info:
The same error appears with -noui switch.
Related packages:
rhpxl-0.39-2
python-2.4.4-1.fc6
Comment 1 Mark Summerfield 2006-11-24 09:45:32 EST
I believe that the reason for this problem is that system-config-display parses
the xorg.conf file and has a bug when it comes to parsing modeline entries.

For example I had this modeline:

Modeline "1400x1050A"  122.61  1400 1488 1640 1880  1050 1051 1054 1087  -HSync
+Vsync

in my Monitor section,

and in my Screen section's Display sub-section I had:

Modes   "1400x1050A"

The problem is that system-config-display _assumes_ that a mode name is of the
form "<int>x<int>".

My solution was to rename my mode to "1400x1050" and change it in both places.
After that system-config-display worked correctly.
Comment 2 Vaclav "sHINOBI" Misek 2006-12-10 16:19:02 EST
The only such a thing I can see are specified frequencies for some modes like
"1024x768_85" etc. It should really be related.
Comment 3 Adam Jackson 2007-03-26 17:36:39 EDT
This should be fixed in rhpxl 0.44.

Note You need to log in before you can comment on or make changes to this bug.