Bug 212816 - mutt fails to authenticate with latest cyrus-sasl
mutt fails to authenticate with latest cyrus-sasl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
http://bugs.mutt.org/cgi-bin/gnatsweb...
:
Depends On:
Blocks: 213271
  Show dependency treegraph
 
Reported: 2006-10-29 06:02 EST by Ferdinand
Modified: 2014-07-29 06:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-29 06:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ferdinand 2006-10-29 06:02:38 EST
When trying to get pop mail with mutt (1.4.2.2-3), sasl authentication will
always fail.  This is due to a change in cyrus-sasl version 2.1.22, as described
in mutt bug 2478. (Open URL, log in with user:guest pass:guest to see it.)

The patch the mutt devs have applied to fix this is here (CVS HEAD):
http://dev.mutt.org/cgi-bin/viewcvs.cgi/mutt/pop_auth.c?r1=3.7&r2=3.8

This patch to pop_auth.c is hard to backport however, because of another patch 
in the mutt src rpm: mutt-1.4-sasl2.patch. But the part that matters is:

-sasl_decode64 (inbuf, strlen (inbuf), buf, LONG_STRING-1, &len) != SASL_OK)
+sasl_decode64 (inbuf+2, strlen (inbuf+2), buf, LONG_STRING-1, &len) != SASL_OK)

I removed the leading spaces and && here to fit it on one line.
I think the other changes in their fix are to "enable SASL plaintext:
$foo_authenticators [as] a more general solution" as their cvs log says.

Since the equivalent line in 1.4 is also altered by the sasl2 patch I'm not sure
how to propose a patch, in fact I tested this fix by editing the sasl2 patch.
Anyway, add '+2' to both 'inbuf's in that line and sasl auth will work again.
Comment 1 Miroslav Lichvar 2006-10-31 10:48:51 EST
Fixed in mutt-1.4.2.2-4.fc6. Thanks.
Comment 2 Fedora Update System 2006-10-31 14:53:57 EST
mutt-1.4.2.2-4.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 jpacner 2014-07-23 10:07:21 EDT
List of patches present on mutt-1.5.20-6.20091214hg736b6a.el6:
http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=5e5acce3e9664eb459e94bbacfedb071d51bb888
Comment 4 jpacner 2014-07-29 06:50:25 EDT
Recovering unwanted changes caused by a badly chosen bug number choice.

Note You need to log in before you can comment on or make changes to this bug.