Bug 212818 - Gaim (crashes) receives signal SIGPIPE, Broken pipe, when logging onto a channel on irc.efnet.org
Gaim (crashes) receives signal SIGPIPE, Broken pipe, when logging onto a chan...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 06:26 EST by Peter Eriksen
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 13:18:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backtrace with and without "handle SIGPIPE nostop". (14.85 KB, text/plain)
2006-10-29 06:26 EST, Peter Eriksen
no flags Details
Disallow libdbus to exit(1) on its socket failure (455 bytes, patch)
2006-11-05 07:13 EST, Jan Kratochvil
no flags Details | Diff
.gdbinit for Comment #1 to catch proper backtrace from exit(1) (60 bytes, text/plain)
2006-11-05 07:14 EST, Jan Kratochvil
no flags Details

  None (edit)
Description Peter Eriksen 2006-10-29 06:26:28 EST
Description of problem:
Gaim crashes, when connecting to a #sslug on irc.efnet.org.

Version-Release number of selected component (if applicable):
[peter@localhost ~]$ rpm -q gaim
gaim-2.0.0-0.17.beta4.fc6
[peter@localhost ~]$ rpm -q gaim-debuginfo
gaim-debuginfo-2.0.0-0.15.beta3.fc6
[peter@localhost ~]$ rpm -q dbus
dbus-0.93-3.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Start Gaim
2. Visit the #sslug chat on irc.efnet.org
3.
  
Actual results:
Program receives signal SIGPIPE, Broken pipe.

Expected results:
Gaim logs on to #sslug.

Additional info:
Comment 1 Peter Eriksen 2006-10-29 06:26:29 EST
Created attachment 139662 [details]
Backtrace with and without "handle SIGPIPE nostop".
Comment 2 Warren Togami 2006-10-30 16:42:26 EST
<roland> warren: it's that application's problem whether it meant to cope with
SIGPIPE, or whether it meant to be killed by it and the socket it's writing to
is broken at that time because of something it did

(Roland McGrath indicating that this is upstream's problem.)
Comment 3 Warren Togami 2006-10-30 16:44:16 EST
<drepper> warren: end don't propose to blindly ignore SIGPIPE
<drepper> warren: the right solution is to use send with the MSG_NOSIGNAL flag

(More suggestions from Ulrich Drepper.)
Comment 4 Luke Schierer 2006-10-30 17:03:27 EST
we only get caught by SIGPIPE when you run in gdb without telling it 
handle SIGPIPE nostop
Comment 5 Luke Schierer 2006-10-30 17:05:11 EST
... except apparently in this case where something weird is going on.
Comment 6 Jan Kratochvil 2006-11-05 07:13:28 EST
Created attachment 140385 [details]
Disallow libdbus to exit(1) on its socket failure

This patch and RPMs at:
http://www.jankratochvil.net/priv/bz212818/
should resolve the DBUS cause. Still it is more a workaround - DBUS should not
fail in the first case. There is SIGPIPE from DBus exiting the process.
Anyway I believe this patch should be included as the DBus functionality is not
the principal functionality of Gaim to cause its quit.
Comment 7 Jan Kratochvil 2006-11-05 07:14:30 EST
Created attachment 140386 [details]
.gdbinit for Comment #1 to catch proper backtrace from exit(1)
Comment 9 Ethan Blanton 2006-11-05 09:58:33 EST
Jan -

That patch definitely seems to fix the symptom, I've applied it to upstream svn.
 I agree that there must be a remaining Gaim or D-BUS bug, but I also agree that
a D-BUS failure should not cause Gaim to fail.

Ethan
Comment 10 Sergio Monteiro Basto 2006-11-06 07:22:23 EST
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=213800#c5
have a short solution ? 
Comment 11 Warren Togami 2006-11-09 12:36:27 EST
http://people.redhat.com/wtogami/temp/gaim/
Please test this FC6 candidate update package here, does this solve your problem?
Comment 12 Peter Eriksen 2006-11-09 14:15:39 EST
(In reply to comment #11)
> http://people.redhat.com/wtogami/temp/gaim/
> Please test this FC6 candidate update package here, does this solve your problem?

This package solves my problem.  Thank you!

~]$ rpm -q gaim
gaim-2.0.0-0.19.beta4.fc6

Note You need to log in before you can comment on or make changes to this bug.