Bug 212819 - [UDP]: Select handling of bad checksums
[UDP]: Select handling of bad checksums
Status: CLOSED DUPLICATE of bug 212321
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 06:39 EST by Kaj J. Niemi
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-09 16:23:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[UDP]: Select handling of bad checksums (4.29 KB, patch)
2006-10-29 06:39 EST, Kaj J. Niemi
no flags Details | Diff
For SOCK_RAW sockets; should be the same as inet_dgram_ops but without udp_poll (3.08 KB, patch)
2006-10-29 06:40 EST, Kaj J. Niemi
no flags Details | Diff

  None (edit)
Description Kaj J. Niemi 2006-10-29 06:39:21 EST
Description of problem:
We originally detected this when a customer of ours had a broken firewall between two servers 
trafficing with eachother using SNMP. If the SNMP datagrams were large enough they got fragmented 
and the firewall code corrupted the the udp checksum. The asynchronous code receiving the snmp 
datagrams then blocked forever which wasn't really supposed to happen at all. Looking at the original 
problem with tcpdump we saw that we get both of the datagrams but in the application code never get 
back from a recvmsg() or similar system call. Some googling around and up turns a bug that got fixed 
in 2.6.10, after RHEL4 branched.

I've attached the patches here for completeness and they are as close to the upstream patches as 
possible.

Patch #1 fixes the problem with handling of udp checksum validation
Patch #2 fixes a problem with SOCK_RAW using the code in Patch #1 which breaks someone's pptp 
server among other things according to the urls. We don't use this code but it is included here for 
completeness.

For more information on Patch #1 see, http://permalink.gmane.org/gmane.linux.kernel.commits.head/
44781
For more information on Patch #2, see http://www.gatago.com/linux/kernel/15477600.html


Version-Release number of selected component (if applicable):
2.6.9-42.0.3
  


Additional info:
It would be nice if you guys could integrate these into the next RHEL4 kernel release or something.

Thanks.
Comment 1 Kaj J. Niemi 2006-10-29 06:39:21 EST
Created attachment 139663 [details]
[UDP]: Select handling of bad checksums
Comment 2 Kaj J. Niemi 2006-10-29 06:40:57 EST
Created attachment 139664 [details]
For SOCK_RAW sockets; should be the same as inet_dgram_ops but without udp_poll
Comment 3 Kaj J. Niemi 2006-10-29 06:47:09 EST
Oh well, looks like someone else hit the same nail on the head. Our problem is the same as bz #212321 
and 212325.
Comment 4 Jason Baron 2007-02-09 16:23:35 EST

*** This bug has been marked as a duplicate of 212321 ***

Note You need to log in before you can comment on or make changes to this bug.