Bug 2128247 - [Fedora 37 beta1.5 installer] Night Light does not work correctly
Summary: [Fedora 37 beta1.5 installer] Night Light does not work correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-20 11:23 UTC by Jehan
Modified: 2022-09-25 00:18 UTC (History)
7 users (show)

Fixed In Version: mutter-43.0-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-25 00:18:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Jehan 2022-09-20 11:23:20 UTC
Description of problem:

Switching the night light mode on and off does not work.

If I go to the "Night Light" tab in Settings and tweak the "Color Temperature" slider directly, it works for a few second (the image goes orange), then gets back to non-orange by itself (the Night Light is still shown switched ON but it's not working).

Version-Release number of selected component (if applicable): whatever is in the Fedora 37 beta 1.5 as downloaded yesterday.

I tested only on the live CD so far, though we already had issues in Fedora 36 lately where the night light was also not working (it used to, in earlier Fedora).

Also I saw other bug reports, such as 2021237 which is about night light not working on multi-monitor setup. But this is a single-monitor setup.


How reproducible: always

Steps to Reproduce:
1. Click the top-right section of the GNOME desktop
2. In the menu, click the "Night Light" button

Actual results: nothing happens

Expected results: the screen should go orange-ish.

Alternatively:
1. Open the "Settings" > Displays > Night Light
2. Switch it ON. So far nothing happens as well.
3. Tweak the "Color Temperature" slider.

Actual results: the night light finally happens, the whole screen goes orange-ish, then after a few seconds, it goes off again (even though it still shows ON, but simply the display is not orange-ish anymore).

Additional info:

Comment 1 Kalev Lember 2022-09-22 11:48:18 UTC
This is possibly fixed with backporting https://src.fedoraproject.org/rpms/mutter/c/13502e95dc17941dbd71442786f22e603c32ac67?branch=rawhide - can you see if it fixes it for you, please?

Comment 2 Jehan 2022-09-22 11:57:58 UTC
I can try. I'll have to build mutter on this machine. I'll try to do this in the next few days.

Comment 3 Kalev Lember 2022-09-22 12:02:57 UTC
No, you don't have to build it locally - I commented here before the build finished. I'll attach it to here shortly.

Comment 4 Fedora Update System 2022-09-22 12:06:14 UTC
FEDORA-2022-c7746c91b6 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-c7746c91b6

Comment 5 Jehan 2022-09-22 12:07:11 UTC
Oh. So it will be a RPM? Will this RPM work fine on a Fedora 36 too? Because in the end, we didn't install Fedora 37 (because of other — unrelated — problems which prevented the install to succeed; though in the end it turned out it was possibly a hardware issue, we had already reverted to Fedora 36), but the same bug is also happening on an up-to-date Fedora 36 so we should be able to test this patch in there too if the RPM is compatible.

Comment 6 Kalev Lember 2022-09-22 12:16:51 UTC
No, that build is only for Fedora 37. Sorry, I am just trying to track down last minute fixes for the 37 release before the freezes start, no idea about Fedora 36.

Comment 7 Jehan 2022-09-22 12:34:49 UTC
I could still just install the RPM inside the Fedora 37 live OS then. But I am guessing it would require at least logging out then back in for the updated mutter to be loaded. And obviously rebooting makes no sense here.

Can we log out/in in the live Fedora environment?

Comment 8 Kalev Lember 2022-09-22 14:27:28 UTC
I believe we can log out/in in the live environment, yes. Looks like kparal has confirmed the fix in https://bodhi.fedoraproject.org/updates/FEDORA-2022-c7746c91b6 though so maybe it's not that important any more for you to double-check it.

Comment 9 Fedora Update System 2022-09-23 01:49:00 UTC
FEDORA-2022-c7746c91b6 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-c7746c91b6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-c7746c91b6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Jehan 2022-09-23 10:06:02 UTC
> Looks like kparal has confirmed the fix

OK. I'll leave it at it, then. :-)

Comment 11 Fedora Update System 2022-09-25 00:18:04 UTC
FEDORA-2022-c7746c91b6 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.