Bug 2128259 - x86_64 .pc files contain incorrect library path
Summary: x86_64 .pc files contain incorrect library path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libwebp
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2130049 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-20 12:22 UTC by Kim Woelders
Modified: 2022-09-27 05:54 UTC (History)
2 users (show)

Fixed In Version: libwebp-1.2.4-2.fc37 libwebp-1.2.4-2.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-25 00:18:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Kim Woelders 2022-09-20 12:22:18 UTC
Description of problem:
pkg-config --libs libwebp gives wrong path causing linker warnings when used to build stuff using libwebp.

Version-Release number of selected component (if applicable):
libwebp-1.2.4-1.fc37.x86_64

How reproducible:
Always

Steps to Reproduce:
$ pkg-config --libs libwebp

Actual results:
-L/usr/lib -lwebp

Expected results:
-lwebp

Additional info:

Comment 1 Fedora Update System 2022-09-22 11:59:01 UTC
FEDORA-2022-6476d33b8c has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-6476d33b8c

Comment 2 Fedora Update System 2022-09-22 11:59:03 UTC
FEDORA-2022-ef95c2bdf5 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ef95c2bdf5

Comment 3 Fedora Update System 2022-09-23 01:48:56 UTC
FEDORA-2022-ef95c2bdf5 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-ef95c2bdf5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ef95c2bdf5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2022-09-23 01:57:27 UTC
FEDORA-2022-6476d33b8c has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-6476d33b8c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-6476d33b8c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-09-25 00:18:03 UTC
FEDORA-2022-ef95c2bdf5 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2022-09-27 01:31:23 UTC
FEDORA-2022-6476d33b8c has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Sandro Mani 2022-09-27 05:54:20 UTC
*** Bug 2130049 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.