Bug 212827 - cifs mount can't list directory - strange limit of count(files) * length(filename)
Summary: cifs mount can't list directory - strange limit of count(files) * length(file...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
urgent
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-29 12:55 UTC by Peter Bieringer
Modified: 2015-01-04 22:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 22:11:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bieringer 2006-10-29 12:55:53 UTC
Description of problem:
There must be an unexpected limit in the cifs kernel module which breaks
listening of directories containing a lot of long file names.

Version-Release number of selected component (if applicable):
Client:
kernel-2.6.18-1.2200.fc5
Server:
samba-3.0.23c-1.fc5


How reproducible:
Always, if directory is filled up

Steps to Reproduce:
1. create a directory on a samba server
2. create file names like e.g.:

$ rm -rf *.txt; filename="`perl -e "print 't' x 80";`";  for i in `seq 1 37`; do
 touch $filename.$i.txt; done
(36 will work)

or

$ rm -rf *.txt; filename="`perl -e "print 't' x 70";`";  for i in `seq 1 40`; do
touch $filename.$i.txt; done
(39 will work)

3. mount this directory via cifs on a client
4. try to list directory:
$ ls /mnt/autofs/store/test/

Actual results:
ls: reading directory /mnt/autofs/store/test/
Invalid argument


Expected results:
Listing of directory works

Additional info:
must be a client side (cifs module problem), smbclient works well.

Comment 1 Peter Bieringer 2006-11-02 10:34:43 UTC
Same happen on another network, here client is also FC6, but server is RHEL4
(samba-3.0.10-1.4E.9)

Comment 2 Jack Tanner 2006-11-03 05:12:12 UTC
Same here. The server is a Windows (2003?) box. RHEL4.4's samba can mount the
folder in question, but FC6's samba-common-3.0.23c-2 complains about 'Invalid
argument'. Removing some files from the folder makes the folder readable again
even to the FC6 samba.


Comment 3 anillo03 2006-11-12 12:45:05 UTC
I had  similar error "cifs mount can't list directory" in FC6 x86_x64 listing
shares from a samba(3.0.14a-ubuntu'breezy')server 
even when smbclient can list it
This drived me crazy.because fc6 kernel have no support for smbfs I get stuck.
I can't figure how to compile smbfs module the supplied fc6 kernel.
So make new big partition 8 gigas at list and download last kernel(2.6.18.2)
and make gconf,make bzImage,make modules,make modules_install,etc...and make a
new boot option, grub ,mkinitrd..etc  (only for stupid avanced users who like
freeze his computer):)
and ... cool smbfs don't work :(
 but cifs is ok  :)) no more problems
so it's seem a kernel or kernel module problem to me

Comment 4 Jack Tanner 2006-11-15 13:01:55 UTC
Could someone update the target version so that this doesn't fall off the radar?
Unless there are two separate bugs, this still persists in FC6.

Comment 5 Peter Bieringer 2006-11-15 18:28:56 UTC
Changed target to FC6

Comment 6 Peter Bieringer 2006-11-15 18:57:10 UTC
Changed priority because no one of Red Hat cares about...btw. RHEL5 beta is also
based on 2.6.18, perhaps this bug exists also here.

Comment 7 Jack Tanner 2006-11-20 21:48:00 UTC
Whoa! WORKSFORME ever since the 2.6.18-1.2849.fc6 kernel update.

Comment 8 Peter Bieringer 2006-12-06 14:09:59 UTC
Can confirm #7


Note You need to log in before you can comment on or make changes to this bug.