Bug 212836 - Review Request: fwfstab - a graphical file system table (fstab) editor
Review Request: fwfstab - a graphical file system table (fstab) editor
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2006-10-29 10:26 EST by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 08:33:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-10-29 10:26:32 EST
Spec URL: http://www.diffingo.com/downloads/fwfstab/fwfstab.spec
SRPM URL: http://www.diffingo.com/downloads/fwfstab/fwfstab-0.01-1.src.rpm
RPM: http://www.diffingo.com/downloads/fwfstab/fwfstab-0.01-1.noarch.rpm
Description:
fwfstab is a graphical file system table (fstab) editor, used to edit the /etc/fstab file. It lets users add, edit or remove new entries in a simple, straight-forward way. It is meant to make the task of editing the file system table easier without sacrificing flexibility.

rpmlint's silent on the binary and SRPM.
Comment 1 Paul F. Johnson 2006-10-29 10:38:44 EST
	--add-category X-Fedora\

needs to be dropped for rawhide - I'd just have

if ?{%fedora} < "7"
        --add-category X-Fedora \
endif

(or something akin to that) around it.

As this application is changing /etc/fstab, can I take it there is something in
the code which checks the UID and then requests the user to log in as root?
Comment 2 Stewart Adam 2006-10-29 13:16:58 EST
Hmmm... The "if" doesn't work, I tried googling but it seems rpm has ifarch,
ifos, etc but not plain ifs. Either way, though, according to here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=212350
desktop-file-utils accepts X-Fedora again now.

As for the permissions - I use PAM to ask for the root password and from there
it's all good.
Comment 4 Parag AN(पराग) 2006-10-31 02:09:06 EST
will review this package
but i got some problems while using this.
I opened my fstab and tried to add cdrom mouting entry there. It did actually
but after applying changes it failed to show that entry why?
Comment 5 Stewart Adam 2006-10-31 08:15:42 EST
Can you post the /etc/fstab and the line you tried to add? I didn't try a cdrom,
but on my computer it successfully wrote new entries to the fstab...
Comment 6 Parag Nemade 2006-11-01 00:19:49 EST
my /etc/fstab
/dev/VolGroup00/LogVol00        /       ext3    defaults        1 1
devpts  /dev/pts        devpts  gid=5,mode=620  0 0
tmpfs   /dev/shm        tmpfs   defaults        0 0
/dev/VolGroup00/LogVol01        /home   ext3    defaults        1 2
/dev/VolGroup00/LogVol02        /usr   ext3    defaults        1 2
proc    /proc   proc    defaults        0 0
sysfs   /sys    sysfs   defaults        0 0
/dev/VolGroup00/LogVol03        swap    swap    defaults        0 0

and i tried to add 
/dev/cdrom
/mnt/cdrom
ext3 

i mean i filled 3 input boxes in Add entry box and then i save but i could not
able to see any new added entry.


will try on other machine also
Comment 7 Stewart Adam 2006-11-01 08:17:19 EST
Worked for me:
$ cat /etc/fstab
...
/dev/cdrom      auto    /mnt/cdrom      defaults        0 0

What where all the fields that you put in? The program will refuse to add a
entry with a black 'filesystem' or 'options' for example, because then it would
cause errors in the fstab.
Comment 8 Parag AN(पराग) 2006-11-01 10:35:16 EST
hi,
 Are you sure above is correct?
I also got it working and got following line
/dev/cdrom      auto    /mnt/cdrom      defaults        1 0

then i immediately gave following command and it failed
[root@localhost ~]# mount /dev/cdrom
mount: mount point auto does not exist

so its wrong. it must be 
/dev/cdrom      /mnt/cdrom      auto  defaults        1 0

and it worked.
check its entering wrong line in /etc/fstab

Comment 10 Parag AN(पराग) 2006-11-02 00:14:01 EST
Are you sure you really fixed bug? i think i am still getting same results as
with old package.
Comment 11 Parag AN(पराग) 2006-11-02 00:16:14 EST
one more thing you increased rpm package release number. AFAIK this bug is
releated with source tarball and if you have modified source tarball then you
must increase tarball version also.

Fix all then will do official review.
Comment 12 Stewart Adam 2006-11-02 17:12:39 EST
Sorry for the troubles - I edited the 'add' function but not the 'edit' one... I
tested both on my machine, it should work as it should now.

Your right it is, but considering I have 0 downloads (apart from here) I just
re-created the tarball... Anyways, I made a new release:
SPEC: http://www.diffingo.com/downloads/fwfstab/fwfstab.spec
SRPM: http://www.diffingo.com/downloads/fwfstab/fwfstab-0.01.1-1.src.rpm
RPM: http://www.diffingo.com/downloads/fwfstab/fwfstab-0.01.1-1.noarch.rpm
Comment 13 Parag AN(पराग) 2006-11-02 23:46:18 EST
Now this package looks ok in its packaging and its functioning.
Comment 14 Parag AN(पराग) 2006-11-02 23:54:16 EST
Review:
+ package builds in mock (development i386) for FC6.
+ rpmlint is silent for RPM and SRPM.
+ source files match upstream.
fb87e760037a9497b1e8f47c8715e65d  fwfstab-0.01.1.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written but NOT properly indented.
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.  License text included in package.
+ %doc is small; no -doc subpackage required.
+ %doc does not affect runtime.
+ COPYING included in %doc.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc files.
+ no -devel subpackage exists
+ no .la files.
+ no translations available
+ Provides: config(fwfstab) = 0.01.1-1.fc6
+ Requires: /bin/bash
            /usr/bin/python
            config(fwfstab) = 0.01.1-1.fc6
            pygtk2
            pygtk2-libglade
            python(abi) = 2.4
            redhat-artwork
            usermode


+ owns the directories it creates.
+ doesn't own any directories it shouldn't.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Desktop file installed succesfully
+ Desktop file is handled correclty in SPEC file.
+ GUI app
+ Followed python packaging guidelines.
APPROVED.
Comment 15 Parag AN(पराग) 2006-11-02 23:59:38 EST
Don't Forget to CLOSE this bug once you import this package in CVS.
Comment 16 Stewart Adam 2006-11-03 08:34:06 EST
Done. Thanks!

Note You need to log in before you can comment on or make changes to this bug.