Bug 212838 - Improve selection of wallpaper for widescreen
Improve selection of wallpaper for widescreen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 10:37 EST by Leo
Modified: 2008-05-07 20:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 20:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo 2006-10-29 10:37:17 EST
Description of problem:
By default FC6 will use 4:3 for any screen. This leads to a lot of ugly
screenshots in the reviews for FC6. Since widescreen are now much more popular
than normal screen, it will be a good idea to figure out a way to pick up the
right wallpaper for the sake of marketing. A lot of distributions have already
achieved this a year before. Time for Fedora to catch up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-10-30 14:44:46 EST
This needs to be handled in the desktop environment, not in some hack in anaconda
Comment 2 Ray Strode [halfline] 2006-10-30 16:17:54 EST
We have another bug about this somewhere but I can't find it off hand.

It's actually been on the TODO list since before fc5.
Comment 3 Matthias Clasen 2006-10-30 18:48:37 EST
"A lot of distributions have already achieved this a year before. Time for
Fedora to catch up."

Care to name a few ? 
And maybe ask them why their patches to the background capplet are not upstream
yet ?
Comment 4 Leo 2006-11-01 14:34:34 EST
I'm speaking from my memory.

Ubuntu seems to do it well. That's with 5.10. It detects my screen resolution
1280:800 during the install and never ask the user a question. Some other
distributions like SuSE and Mandriva seem fine too. But I haven't tried them for
a long time.
Comment 5 Brian McMinn 2007-01-07 17:11:44 EST
The other bug on this is probably bug 189421 but I'll let someone else decide
which of the two bugs to mark as a duplicate.
Comment 6 Bastien Nocera 2007-02-15 13:22:00 EST
I don't understand the problem.

Is the problem that the default resolution selected is a 4:3 resolution (in
which case it'd be X and how the monitor is detected that's a problem), or is it
that the default backgrounds don't look good on a widescreen (which would be for
the fedora artwork to fix)?

Or is it that the background preferences don't "show" that the screen in
widescreen in the previews?
Comment 7 Leo 2007-02-15 20:41:56 EST
The former.
Comment 8 Bastien Nocera 2007-02-16 04:30:37 EST
Pushing back to Anaconda, as it is were the first X config happens.
Comment 9 Jeremy Katz 2007-02-16 09:38:58 EST
Actually, we don't configure any resolutions anymore, X automagically figures
things out.
Comment 10 Ray Strode [halfline] 2007-02-16 10:51:19 EST
The problem is that the background capplet isn't smart about choosing wallpapers.

It should look for foo-wide.png and use it instead of foo.png if the aspect
ratio is wide or something along those lines.

An alternative that we tried and failed to do in the past, was make SVGs
dynamically relayout themselves to fit the aspect ratio.  It turned out that it
required svg 1.2 to do and librsvg didn't support it.
Comment 11 Bastien Nocera 2007-02-19 10:13:03 EST
I really don't see how this is a problem of the background capplet. I don't
think we want to special case distro-provided background images for 4:3 and
widescreen ratios in the capplet (which would mean also working around this in
libbackground).
Comment 12 Ray Strode [halfline] 2007-02-19 10:55:16 EST
Well,this isn't supposed to be distro-specific.

The idea is that when a new user logs in, the background they get shouldn't look
smooshed or stretched until they manually go and fix it.  The out of the box
experience should be better than that.

Now how we go about fixing that is another matter, but it's something we've
wanted to do since before fc5 and have always had to punt on.
Comment 13 Jeremy Katz 2007-02-26 13:41:13 EST
And it really has to be done at login time and not with hacks in anaconda or
whatnot.  Especially as we want things to work correctly with the live CD.
Comment 14 Bug Zapper 2008-04-03 14:33:46 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 15 Bug Zapper 2008-05-06 20:58:25 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 16 Matthias Clasen 2008-05-07 20:39:29 EDT
The default background in F9 is a multiresolution slideshow, and nautilus will
automatically pick the best resolution to match the screen.

Note You need to log in before you can comment on or make changes to this bug.