Bug 21285 - DHCPD configuration tool does not configure properly.
DHCPD configuration tool does not configure properly.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-23 14:01 EST by Rishi Gangoly
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rishi Gangoly 2000-11-23 14:01:48 EST
DHCPD in linuxconf does not configure properly.

1. it gives an error saying that /var/state/dhcp/dhcpd.leases file does not exist.... 

   It could do a 'touch /var/state/dhcp/dhcpd.leases to while it creates a dhcp server.

2. if the Update DNS [x] option is checked from the cron it runs a script dhcp2dns.sh . 
   this file basically assumes that the dhcpd.leases table is located in /etc/dhcpd.leases 
   when actually the location of the file itself has changed in the new dhcpd*rpm

   The hack I use is create a softlink for /etc/dhcpd.leases 
   to point -> to /var/state/dhcp/dhcpd.leases

3. Lastly, this dhcp2dns.sh script keeps generating an output 'reload initiated' every 
    5 minutes and fills up the crontab. Is this information really required?

Location for the file is /usr/lib/linuxconf/lib/dhcp2dns.sh

Regards

Rishi
Comment 1 Rishi Gangoly 2001-07-16 23:55:36 EDT
I'd like add some more clarifications to this bug that I reported.

The bug is with linuxconf*rpm and not dhcpd*rpm

Also I noticed another thing. Since the DHCP2DNS script reads the dhcpd.leases 
file and converts them into entries in the DNS table 
in /var/named/whatever.com, certain things need to be kept in mind.

1. named (bind) does not accept special characters like "_" (underscore) etc. 
If the HOSTNAME in the dhcpd.leases table has a host with such a name then 
while doing a sync between the two tables, it corrupts the integrity of the DNS 
table.  Sometimes named does not function properly because of invalid entires.

2. The other problem we noticed is that if a HOSTNAME has Upper and Lower case, 
then named goes for a toss too. There was this guy who had the computer name 
called KRISHNANs with the 's' at the end in lower case. The DNS table got this 
entry too. and because of that named stopped working correctly.... and my mail 
server (sendmail) stopped working too. Weird but that's what happened.

Suggestion: when doint the sync, convert all HOSTNAMES from dhcpd.leases to the 
DNS table into lower case. Convert all "_" (underscores) to "-" (hyphens)

Comment 2 Elliot Lee 2001-07-20 12:48:15 EDT
dhcp.leases problem fixed.

reassigning to linuxconf for the rest.

Apologies for the unresponsiveness of the previous dhcp packager...
Comment 3 Brent Fox 2002-06-05 12:16:02 EDT
Closing because we don't ship linuxconf anymore
Comment 4 Red Hat Bugzilla 2006-02-21 13:47:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.