Bug 212857 - NForce-2: no agpgart
NForce-2: no agpgart
Status: CLOSED DUPLICATE of bug 211941
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-10-29 14:07 EST by e.mergl
Modified: 2015-01-04 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-24 22:41:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of dmesg of the re-compiled kernel (7.41 KB, application/octet-stream)
2006-10-31 15:47 EST, e.mergl
no flags Details
/var/log/messages of the original kernel (8.25 KB, application/octet-stream)
2006-10-31 15:48 EST, e.mergl
no flags Details
Xorg.log of the re-compiled kernel, the original log with the error message I don't have anymore (9.99 KB, application/octet-stream)
2006-10-31 15:49 EST, e.mergl
no flags Details

  None (edit)
Description e.mergl 2006-10-29 14:07:53 EST
Description of problem:

NForce-2: in /var/log/messages the usual message 
           'Detected NVIDIA nForce2 chipset'
           is missing and the X-Server complains about missing agpgart.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
Actual results:

AGP not configured, X-Server can not use DRI => applications like 
googleearth are dog-slow ...

Expected results:

Additional info:

re-compiling the kernel with the shipped kernel-2.6.18-i686.config
fixes the problem.
Comment 1 Dave Jones 2006-10-31 15:16:48 EST
Please attach the output of dmesg after booting the FC6 kernel.
Also the /var/log/Xorg.0.log
Comment 2 e.mergl 2006-10-31 15:47:15 EST
Created attachment 139894 [details]
output of dmesg of the re-compiled kernel
Comment 3 e.mergl 2006-10-31 15:48:25 EST
Created attachment 139895 [details]
/var/log/messages of the original kernel
Comment 4 e.mergl 2006-10-31 15:49:19 EST
Created attachment 139897 [details]
Xorg.log of the re-compiled kernel, the original log with the error message I don't have anymore
Comment 5 e.mergl 2006-10-31 15:55:17 EST
Today I installed FC6 on another machine, which has pretty much the same HW:
same MoBo, same CPU, same Memory, but different HD and graphics: the first where
the error occured has a Radeon 9200 graphics card. The machine I installed today
has a Matrox G550 graphics card. Strange enough on the second machine everything 
worked correct right out of the box:
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
This is very confusing.

Comment 6 e.mergl 2006-10-31 15:57:31 EST
by the way: the MoBo is an Asus A7N8X-E Deluxe.
BIOS settings of both machines are identical.
Comment 7 Dave Jones 2006-11-06 23:41:34 EST
ah, I think this is the 'installer installs a 586 kernel by default' bug.
See ..


Let me know if it works when you install a 686 kernel.
Comment 8 Dave Jones 2006-11-24 22:41:33 EST

*** This bug has been marked as a duplicate of 211941 ***

Note You need to log in before you can comment on or make changes to this bug.