Bug 2128660 - Maximized GVim window on secondary screen displayed on both screens due to direct scanout
Summary: Maximized GVim window on secondary screen displayed on both screens due to di...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F37FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-09-21 10:35 UTC by Vít Ondruch
Modified: 2022-09-25 00:18 UTC (History)
8 users (show)

Fixed In Version: mutter-43.0-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-25 00:18:07 UTC
Type: Bug


Attachments (Terms of Use)
Reproducer video (2.56 MB, video/mp4)
2022-09-21 14:27 UTC, Vít Ondruch
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME mutter issues 2387 0 None closed Maximized GVim window on secondary screen displayed on both screens due to direct scanout 2022-09-21 10:35:46 UTC

Description Vít Ondruch 2022-09-21 10:35:34 UTC
Description of problem:
When the GVim window is maximized on secondary screen, it suddenly appears also on the primary screen. Please see the attached video:

https://photos.app.goo.gl/VxKBr8DbsPamSLDo7

I am not really sure if this is issue in GVim, Gnome, Mutter, XWayland or somewhere else.


Version-Release number of selected component (if applicable):
~~~
$ rpm -q gnome-shell
gnome-shell-43~beta-2.fc38.x86_64

$ rpm -qf `which gvim`
vim-X11-9.0.189-1.fc38.x86_64

$ rpm -q mutter
mutter-43~beta-1.fc38.x86_64
~~~


How reproducible:
Always


Steps to Reproduce:
1. Open GVim on secondary screend and maximize
2.
3.

Actual results:
The maximized window is displayed on secondary as well as on primary screen, where the window on primary screen can't be focused


Expected results:
Window is displayed only on one screen.


Additional info:

Comment 1 Fedora Blocker Bugs Application 2022-09-21 12:51:05 UTC
Proposed as a Freeze Exception for 37-final by Fedora user vondruch using the blocker tracking app because:

 Maximizing window makes the window visible on secondary, but also on primary screen. This is very confusing for users. This issue possibly affects all X11 apps. Several are listed in the upstrem ticket [1].

[1] https://gitlab.gnome.org/GNOME/mutter/-/issues/2387

Comment 2 Kamil Páral 2022-09-21 13:55:58 UTC
> https://photos.app.goo.gl/VxKBr8DbsPamSLDo7

It says "Album is empty". Why don't you upload the video to the upstream issue or here directly?

Comment 3 Vít Ondruch 2022-09-21 14:27:28 UTC
Created attachment 1913315 [details]
Reproducer video

(In reply to Kamil Páral from comment #2)
> > https://photos.app.goo.gl/VxKBr8DbsPamSLDo7
> 
> It says "Album is empty".

I have deleted the video, but it is back up.

> Why don't you upload the video to the upstream

It seems that GL does not support video upload.

> issue or here directly?

Probably good idea, since I have created the ticket already :)

Comment 4 Kamil Páral 2022-09-21 14:38:04 UTC
Interesting, I can't reproduce this. GVim gets maximized on the secondary screen only, for me.

> It seems that GL does not support video upload.

It does, but perhaps only certain types, not sure. I do upload webm videos regularly.

Comment 5 Kamil Páral 2022-09-21 16:31:29 UTC
Actually, I just saw it with the Atom IDE. When I maximized it on the *primary* screen, it got duplicated on the secondary screen (just a picture, non-clickable). When unmaximized, the copy disappeared.

Comment 6 Jonas Ådahl 2022-09-21 18:31:55 UTC
The fix for this landed upstream and will be part of mutter-43.1.

Comment 7 Kalev Lember 2022-09-22 11:43:13 UTC
I went ahead and backported this in https://src.fedoraproject.org/rpms/mutter/c/332684b6adab3ab581bfb415db35bb9929d58c22?branch=rawhide

Comment 8 Fedora Update System 2022-09-22 12:06:17 UTC
FEDORA-2022-c7746c91b6 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-c7746c91b6

Comment 9 Kamil Páral 2022-09-22 12:47:48 UTC
When I demaximize GVim or Atom IDE window on the primary screen, there is a short flicker on the secondary screen which shouldn't be there. But apart from that, this issue seems now solved, with that patch applied.

Comment 10 Kalev Lember 2022-09-22 14:29:41 UTC
Awesome, thanks for confirming!

Can you file the flicker issue upstream, please? I don't know mutter code at all and it would be best if upstream can take a look.

Comment 11 Fedora Update System 2022-09-23 01:49:02 UTC
FEDORA-2022-c7746c91b6 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-c7746c91b6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-c7746c91b6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Vít Ondruch 2022-09-23 07:35:17 UTC
Works for me as well. Thx for backporting the fix.

Comment 13 Fedora Update System 2022-09-25 00:18:07 UTC
FEDORA-2022-c7746c91b6 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.