Bug 212886 - Removable usb hard drive doesn't mount on boot
Removable usb hard drive doesn't mount on boot
Status: CLOSED DUPLICATE of bug 204396
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 17:54 EST by Jonathan Ryshpan
Modified: 2007-12-31 01:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 01:44:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Ryshpan 2006-10-29 17:54:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
The drive, a Maxtor 300 GB removable hard drive on the USB bus doean't mount when the system is booted.  Nor are the files /dev/sda and /dev/sda1, which are the device files for this device created, which makes it impossible for the mount command to mount the drive.  However if the drive is unplugged from the USB bus and then plugged in again, the files /dev/sda and /dev/sda1 are created, and if KDE is running, KDE even asks if the drive should be mounted.

To be exact about the drive:
$ lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 003: ID 1241:1177 Belkin F8E842-DL Mouse
Bus 003 Device 004: ID 0d49:3210 Maxtor
Bus 003 Device 001: ID 0000:0000


Version-Release number of selected component (if applicable):
udev-095-14

How reproducible:
Always


Steps to Reproduce:
1.Boot Linux
2.Log in and perform 
  $ ls /dev/sda*
  ls: /dev/sda*: No such file or directory
3.Remove the USB plug from the drive.
  There's a little activity visible on the drive's lights
4.Perform
  $ ls /dev/sda*
  /dev/sda  /dev/sda1

Actual Results:


Expected Results:


Additional info:
This breaks my automatic backup system run by anacron, unless I remember to unplug and plug back in the removable drive pretty quick.
Comment 1 Harald Hoyer 2006-10-30 10:00:42 EST
similar to #204396
Comment 2 Jon Stanley 2007-12-31 01:44:16 EST

*** This bug has been marked as a duplicate of 204396 ***

Note You need to log in before you can comment on or make changes to this bug.