Bug 212901 - FC6 no sound output using cx88-alsa
FC6 no sound output using cx88-alsa
Status: CLOSED DUPLICATE of bug 232217
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2006-10-29 21:01 EST by James Rankin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-22 07:26:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
scsconfig report from Soundcard Detection tool (52.64 KB, text/plain)
2006-10-29 21:01 EST, James Rankin
no flags Details

  None (edit)
Description James Rankin 2006-10-29 21:01:52 EST
Description of problem:
I did a clean install of the final release version of FC6 today... sound is no
longer working.
Using FC4 and FC5, sound did work using the cx88-alsa module; no hardware has
been changed.
I'm running the current i686 kernel for FC6; I had to manually remove the i586
kernel after install and replace it with the correct i686 kernel.

I've tried to modprobe cx88-alsa a few times, and have rebooted several times...
surprisingly, I did get sound to work in Totem ONCE only. After rebooting, no
more sound again, and 'modprobe cx88-alsa' no longer works.

Version-Release number of selected component (if applicable):

------ rpm -q alsa-lib --------

------- rpm -q alsa-utils --------

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
scsconfig.log is attached, as the Soundcard Detection tool requests.
Please let me know what other info I can provide! Thanks!
Comment 1 James Rankin 2006-10-29 21:01:53 EST
Created attachment 139688 [details]
scsconfig report from Soundcard Detection tool
Comment 2 James Rankin 2006-10-29 21:48:24 EST
One more thing to add...

After rebooting again, sound still didn't work. modprobe cx88-alsa still didn't
** If I play a flash animation using Adobe Flash 9 Beta, sound DOES work. Only
after this happens, sound will continue to work in Totem.
Despite both of these things still functioning, I'm still getting most sound
events thru the PC speaker. For example, if I hit tab a few times in a bash
shell, I get an old PC speaker beep.
So something is clearly still not working properly. I have no idea how to
explain what Flash 9 is doing.
Comment 3 James Rankin 2006-10-29 22:24:54 EST
Sorry - I can't reproduce this. Rebooting, trying modprobe again, and running
flash did not restore sound.
This must have been a coincidence. I have not found the reason why sound was
restored previously (flash doesn't appear to have done anything, which makes
more sense).
Comment 4 Martin Stransky 2006-10-30 02:34:01 EST
You have two cards, the first one is:

00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio
Controller (rev a2)

and the second one:

01:06.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder (rev 05)
01:06.1 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder [Audio Port] (rev 05)
01:06.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder [MPEG Port] (rev 05)

Which one would you like to use?
Comment 5 James Rankin 2006-10-30 06:03:59 EST
The first one would be better... it's the integrated sound card. 
Comment 6 John Thacker 2006-10-30 09:35:51 EST
Changing version to fc6 from test3.
Comment 7 Martin Stransky 2006-12-14 06:29:33 EST
Could you please check the latest drivers / packages? (ALSA 1.0.14rc1)
How-to is here:


Comment 8 Martin Stransky 2007-03-22 07:26:42 EDT

*** This bug has been marked as a duplicate of 232217 ***

Note You need to log in before you can comment on or make changes to this bug.