Bug 212936 - gfortan internal compiler error (segfault) regression
Summary: gfortan internal compiler error (segfault) regression
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 6
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-30 08:32 UTC by Ben Webb
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.1.1-32
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 13:01:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test Fortan module (704 bytes, text/plain)
2006-10-30 08:32 UTC, Ben Webb
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 29641 None None None Never

Description Ben Webb 2006-10-30 08:32:05 UTC
Simple compilation of the attached Fortran module causes gfortran to segfault.


Version-Release number of selected component (if applicable):
gcc-gfortran-4.1.1-30 (tested on i686 and x86_64, Fedora Core 6)

How reproducible:
Every time

Steps to Reproduce:
1. Try to compile the attached Fortran module with "gfortran -c testfunc.F90"
  
Actual results:
gfortran dies with a segfault (pasted output below):

testfunc.F90: In function 'testfunc':
testfunc.F90:32: internal compiler error: Segmentation fault


Expected results:
gfortran compiles testfunc.F90 to testfunc.o.


Additional info:
gfortran functions correctly under Fedora Core 5 (gcc-gfortran-4.1.1-1.fc5), at
least on i686 (don't have an FC5 x86_64 machine to test it on right now). The
attached testcase is a minimal example from a large Fortran 90 application,
which now fails to compile due to the upgrade from FC5 to FC6.

Comment 1 Ben Webb 2006-10-30 08:32:05 UTC
Created attachment 139702 [details]
Test Fortan module

Comment 2 Yusuf Ma 2006-10-31 08:03:58 UTC
I have the similar problem when I tried to compile the "Hello World!" C program.
The "internal compiler error: Segmentation fault" error message was given.

The command:
gcc -c hello.c

gcc version:
4.1.1-30

hardware:
athlon

Comment 3 Jakub Jelinek 2006-10-31 08:31:03 UTC
Wrt comment #2, please don't hijack bugs with completely unrelated stuff.
This bugreport is about a particular bug in Fortran frontend (which has been
fixed already in CVS and will be fixed in next gcc-gfortran rpms), you are
compiling a C program.  If your bug is reproducable, then file a different bug
with all the details needed to reproduce it (preprocessed source, command line
options), but if you are trying just a simple hello world program, it is much
more likely that you have hardware problems.

Comment 4 Jakub Jelinek 2006-11-05 13:01:59 UTC
PR29641 fix backported in gcc-4.1.1-32.


Note You need to log in before you can comment on or make changes to this bug.