Bug 212947 - Cifs mount generates strange errors 2.6.18
Summary: Cifs mount generates strange errors 2.6.18
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-30 09:41 UTC by Karl Lattimer
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: kernel-2.6.19-1.2911.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 15:44:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karl Lattimer 2006-10-30 09:41:09 UTC
Description of problem:
CIFS mount generates strange errors

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
Always

Steps to Reproduce:
1.Mount a cifs file system from a windows 2003 server, like so
mount -t cifs //apollo/general apollo/ -o Username=Administrator,uid=klattimer
2.Browse folders on the CIFS filesystem
  
Actual results:
Command line output
ls: reading directory .: Invalid argument

Expected results:
Directory listing displayed.

Additional info:
This problem only applies to 2.6.18 kernels, the 2.6.17 kernels didn't display
this problem.

Comment 1 Jason Trost 2006-11-03 22:01:00 UTC
problem also occurs on FC5 (2.6.18-1.2200.fc5) but works on 2.6.17-1.2174_FC5
with smbd Version 3.0.23c-1.fc5

It allows you to cd to a directory and then read/write, but ls fails completely


Comment 2 Michael Sellers 2006-11-06 19:41:31 UTC
same problem

Comment 3 Steve French 2006-11-25 20:44:39 UTC
Fixed now and available in FC update (block size was shrunk in FC update,
affecting readdir).  Duplicate of various bug numbers,  including bug 212123

This should be returned


Note You need to log in before you can comment on or make changes to this bug.