Bug 212968 - kernel-xen-devel packages all of /xen/
kernel-xen-devel packages all of /xen/
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Don Zickus
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 07:48 EST by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:14:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-10-30 07:48:36 EST
Description of problem:
The kernel-xen-devel package contains the entire /xen/ build, including all
source and object files. 

kernel-devel is there mainly just to allow modules to be built against a kernel,
 so I can't see why we'd be packaging all these hypervisor files; and it results
in inflated -devel packages:

4.6M Oct 27 06:04 Server/kernel-devel-2.6.18-1.2739.el5.i686.rpm
13M  Oct 27 06:05 Server/kernel-xen-devel-2.6.18-1.2739.el5.i686.rpm
Comment 1 Rik van Riel 2006-11-17 10:28:19 EST
I am not sure why we include the /xen/ directory AT ALL.

Should it not be enough to only include linux/include/xen/ ?
Comment 2 RHEL Product and Program Management 2006-11-17 10:41:06 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Rik van Riel 2006-12-14 16:40:26 EST
OK, it looks like fixing this is non-trivial for some reason :(

Simply not copying the files in the spec file makes rpmbuild run into a
different error:

RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/src/debug/kernel-2.6.18/xen/arch/x86/acpi/boot.c
   /usr/src/debug/kernel-2.6.18/xen/arch/x86/apic.c
   /usr/src/debug/kernel-2.6.18/xen/arch/x86/bitops.c
   /usr/src/debug/kernel-2.6.18/xen/arch/x86/boot/x86_64.S
   /usr/src/debug/kernel-2.6.18/xen/arch/x86/compat.c
   /usr/src/debug/kernel-2.6.18/xen/arch/x86/cpu/amd.c
...

This is quite interesting since there does not seem to be anything in the spec
file copying the things to that directory.  Probably some debuginfo build magic
from /usr/lib/rpm.

The question is, why does this not get called (or called differently?) if we do
copy all of xen/ into $BUILDROOT/usr/src/kernel ?
Comment 6 RHEL Product and Program Management 2007-03-14 18:01:59 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 7 Don Zickus 2007-07-13 12:22:23 EDT
in kernel-2.6.18-34.el5
(actually before then but..)
Comment 9 Mike Gahagan 2007-08-03 11:23:15 EDT
/xen/ is now gone from -36.
Comment 11 errata-xmlrpc 2007-11-07 14:14:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.