Bug 212978 - Incorrect number of CPUs for Pentium D960
Summary: Incorrect number of CPUs for Pentium D960
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-30 13:57 UTC by J
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 23:09:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description J 2006-10-30 13:57:04 UTC
Description of problem:

Only 1 CPU is listed under /proc/cpuinfo for a dual-core CPU (Pentium D960)
Note: This appears to be unrelated to anaconda bug because of the version of the
kernel in use...

Version-Release number of selected component (if applicable):

Linux 172.16.1.33 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686
i686 i386 GNU/Linux
 
Actual results:
> cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 6
model name      : Intel(R) Pentium(R) D CPU 3.60GHz
stepping        : 4
cpu MHz         : 2400.000
cache size      : 2048 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 6
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat 
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc up pni 
monitor ds_cpl vmx est cid cx16 xtpr lahf_lm
bogomips        : 7199.22

Expected results:

( At least ):
...
cpu cores       : 2
...


Steps attempted to resolve:
Removed and reinstalled i686 kernel.
( Thinking it was an anaconda bug. )

Other knowns:
Pentium D950 (same motherboard, Intel D965WH, installed as 64 bit returns two
core processors (and I think, 2 siblings)

Comment 1 J 2006-10-30 16:42:48 UTC
It ocurred to me that I should also add this:
Per Intel, I am booting the board with the flags: ALL-GENERIC-IDE PCI=NOMMCONF
Since I have no idea what the second one does, I figured I'd mention it.

Comment 2 J 2006-10-30 23:09:34 UTC
The BIOS has a setting to force the processor into single processor mode. 
Unfortunately, it's wording is a little confusing: "Enable single processor
mode" "disabled" is the setting to get dual processing power from it.


Note You need to log in before you can comment on or make changes to this bug.