Bug 212986 - System with 4gb memory has only 3gb allocated.
System with 4gb memory has only 3gb allocated.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 09:42 EST by Mat
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 11:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mat 2006-10-30 09:42:50 EST
Description of problem:
4gb memory in system only displays as ~3 GB.  Rebooted and tried memtest which
shows all 4gb memory.  Previous FC5 showed all 4gb.

Version-Release number of selected component (if applicable):
uname -rvpsm
Linux 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 athlon
(Opteron 170)

How reproducible:
Always

Steps to Reproduce:
1. Boot current release i686 kerenel ( non PAE )
2.
3.
  
Actual results:
 dmesg | grep mem
Memory: 3103988k/4194304k available (2138k kernel code, 40368k reserved, 868k
data, 240k init, 2228160k highmem)
Freeing initrd memory: 2242k freed
highmem bounce pool size: 64 pages
Total HugeTLB memory allocated, 0
Non-volatile memory driver v1.2
Freeing unused kernel memory: 240k freed
ohci_hcd 0000:00:02.0: irq 225, io mem 0xd5003000
ehci_hcd 0000:00:02.1: irq 233, io mem 0xfeb00000
/dev/vmnet: hub 0 does not exist, allocating memory.

Expected results:
Ability to use 4gb.

Additional info:
Comment 1 Konrad Rzeszutek 2006-10-30 11:10:59 EST
It says : "4194304k". The kernel does see the 4GB. IF you can attach the full
dmesg, it will point otu to where the 1GB is going.
Comment 2 Mat 2006-10-31 01:41:44 EST
After looking at the full dmesg, I noticed towards the top it says to use a PAE
kernel even though I have 4GB installed ( 4 x 1024 Corsair Cas2 DDR400 ).  So
I've changed to the PAE kernel which has resolved the issue.

If you would like me to reboot to a non PAE kernel and paste the output, I am
quite happy to do so, however this is the PAE output.  Notice the 4224MB HIMEM.
   I'm not sure how it comes to this figure as 4 x 1024 = 4096mb.

Linux version 2.6.18-1.2798.fc6PAE (brewbuilder@hs20-bc2-4.build.redhat.com)
(gcc version 4.1.1 20061011 (Red Hat 4.1.1-30)) #1 SMP Mon Oct 16 14:54:22 EDT 2006
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009e800 (usable)
 BIOS-e820: 000000000009e800 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 00000000bfff0000 (usable)
 BIOS-e820: 00000000bfff0000 - 00000000bfff3000 (ACPI NVS)
 BIOS-e820: 00000000bfff3000 - 00000000c0000000 (ACPI data)
 BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
 BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
 BIOS-e820: 0000000100000000 - 0000000140000000 (usable)
4224MB HIGHMEM available.
896MB LOWMEM available.
found SMP MP-table at 000f59c0
NX (Execute Disable) protection: active
On node 0 totalpages: 1310720
  DMA zone: 4096 pages, LIFO batch:0
  Normal zone: 225280 pages, LIFO batch:31
  HighMem zone: 1081344 pages, LIFO batch:31

The non PAE kernel only allocated 3200MB of HIMEM on my system.  Would it
because it thinks I have > 4gb with the 4224mb. ?
Comment 3 Konrad Rzeszutek 2006-10-31 11:01:39 EST
The reason why the non-PAE kernel allocated the 3.2GB is b/c it cannot use the
other memory. This is due to how much the kernel can map each page (4KB) in the
memory. 

I am closing the bug as NOTABUG. Thanks for finding the solution.

Note You need to log in before you can comment on or make changes to this bug.