Bug 212988 - OpenOffice.org Crashes At Startup for non-root users
OpenOffice.org Crashes At Startup for non-root users
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 09:45 EST by Matthew Keller
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.4-5.5.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 03:24:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from strace /usr/lib/openoffice.org2.0/program/soffice.bin > /tmp/ooorun.log 2>&1 as non-root user (1.46 MB, text/plain)
2006-10-31 09:59 EST, Matthew Keller
no flags Details

  None (edit)
Description Matthew Keller 2006-10-30 09:45:46 EST
Description of problem:

OpenOffice.org product as ships with FC6 crashes when run by a non-root user.
SELinux and prelinking have been disabled to rule those out. See Additional
Info: below for the OO.o-provided crashdump.

Version-Release number of selected component (if applicable):

2.0.4-5.3

How reproducible:

Every time.

Steps to Reproduce:
1. Execute any oo.o program as a non-root user
2. Wait for splash screen to finish
3. Read the crashdump (provided below)
  
Additional info:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-30-i386
(V)    kernel is: Linux 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.3-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x7e2cf28: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x22f28
0x7e2dbbb: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23bbb
0x3d5420:  + 0x420 (__kernel_sigreturn + 0x0)
0x400591: /lib/libc.so.6 + 0x2a591 (abort + 0x101)
0x1c5740: /usr/lib/libstdc++.so.6 + 0xb5740
(__gnu_cxx::__verbose_terminate_handler() + 0x150)
0x1c3225: /usr/lib/libstdc++.so.6 + 0xb3225
0x1c3262: /usr/lib/libstdc++.so.6 + 0xb3262
0x1c339a: /usr/lib/libstdc++.so.6 + 0xb339a
0x358c194: /usr/lib/openoffice.org2.0/program/libgcc3_uno.so + 0x9194
0x358cb76: /usr/lib/openoffice.org2.0/program/libgcc3_uno.so + 0x9b76
0x358ae13: /usr/lib/openoffice.org2.0/program/libgcc3_uno.so + 0x7e13
0x358a248: /usr/lib/openoffice.org2.0/program/libgcc3_uno.so + 0x7248
0x11c088f: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x1688f (cppu::throwException(com::sun::star::uno::Any const&) + 0x1ff)
0x119207e: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x6407e
(ucbhelper::cancelCommandExecution(com::sun::star::ucb::IOErrorCode,
com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&,
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&,
rtl::OUString const&,
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandProcessor> const&) +
0x8e)
0x1b156c1: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x476c1
0x1afb116: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x2d116
0x1ada657: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0xc657
0x1ae2797: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x14797
0x1148ae5: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1aae5
0x114de53: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1fe53
(ucb::Content::executeCommand(rtl::OUString const&, com::sun::star::uno::Any
const&) + 0xb3)
0x105773e: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x5773e
0x1059933: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x59933
0x105a820: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x5a820
(utl::UcbLockBytes::CreateLockBytes(com::sun::star::uno::Reference<com::sun::star::ucb::XContent>
const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&, unsigned short,
com::sun::star::uno::Reference<com::sun::star::task::XInteractionHandler>
const&, utl::UcbLockBytesHandler*) + 0x660)
0x1069b84: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x69b84
0x106a63f: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x6a63f
(utl::UcbStreamHelper::CreateStream(String const&, unsigned short,
utl::UcbLockBytesHandler*, unsigned char) + 0x3f)
0x17913d9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x993d9
0x195e3e9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x2663e9
0x195e684: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x266684
(SfxDispatcher::SfxDispatcher(SfxDispatcher*) + 0x34)
0x178c403: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x94403
0x177de3a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x85e3a
(SfxApplication::GetOrCreate() + 0x9a)
0x1988424: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x290424
0x198876a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x29076a
0x11deea5: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x34ea5
0x11de258: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x34258
0x11de315: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x34315
0x11e0b4e: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x36b4e
0x11de258: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x34258
0x11de36d: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x3436d
0x2231eb0: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xaeb0
0x222d18b: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x618b
0x5646bf: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x246bf
(desktop::Desktop::Main() + 0xacf)
0x2c5926c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9126c
0x2c59375: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x91375 (SVMain()
+ 0x35)
0x556a69: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x16a69 (sal_main +
0x59)
0x556af4: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x16af4 (main + 0x44)
0x3ebf2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4a1
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00f58000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x0085c000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x00264000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x00f98000)
	libdl.so.2 => /lib/libdl.so.2 (0x00110000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00eef000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x00185000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00dfe000)
	libm.so.6 => /lib/libm.so.6 (0x00ab6000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x007ac000)
	libc.so.6 => /lib/libc.so.6 (0x00388000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00f5c000)
	/lib/ld-linux.so.2 (0x0016a000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2006-10-31 05:46:55 EST
very strange, still looks like the first UNO exception which would normally
point to a selinux issue. Could you strace it for me and attach the output, e.g. 

strace /usr/lib/openoffice.org2.0/program/soffice.bin > /tmp/ooorun.log 2>&1
Comment 2 Matthew Keller 2006-10-31 09:59:41 EST
Created attachment 139857 [details]
output from strace /usr/lib/openoffice.org2.0/program/soffice.bin > /tmp/ooorun.log 2>&1 as non-root user
Comment 3 Caolan McNamara 2006-10-31 10:21:58 EST
open("/home/kellermg/.execoooLSh9yE", O_RDWR|O_CREAT|O_EXCL|O_LARGEFILE, 0600) = 28
unlink("/home/kellermg/.execoooLSh9yE") = 0
ftruncate64(28, 108)                    = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_SHARED, 28, 0) = -1 ENODEV (No such
device)
mmap2(NULL, 4096, PROT_READ|PROT_EXEC, MAP_SHARED, 28, 0) = 0x5d2000

should be like...

open("/home/caolan/.execooo3gekkC", O_RDWR|O_CREAT|O_EXCL|O_LARGEFILE, 0600) = 27
unlink("/home/caolan/.execooo3gekkC")   = 0
ftruncate64(27, 108)                    = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_SHARED, 27, 0) = 0xb47bf000
mmap2(NULL, 4096, PROT_READ|PROT_EXEC, MAP_SHARED, 27, 0) = 0x203000

might be the way /home is mounted, maybe need to re-work some of the fallback
stuff here to try another way. home isn't mounted read-only or something like that ?
Comment 4 Matthew Keller 2006-10-31 10:46:59 EST
Erg I missed that. /home/kellermg is an EncFS FUSE filesystem. That said I've
been doing the same thing since, oh 2003 or early 2004 on previous versions of
FC and OpenOffice. The version of EncFS hasn't changed since April, and I was
using FC5/OO on the same filesystem until I upgraded last week.

So you can probably reduce the urgency, I'm sorry I didn't dive into that
deeper. Something still had to change with how OO deals with that.
Comment 5 Caolan McNamara 2006-10-31 11:05:11 EST
Yeah, I need to detect the failure, try again with /tmp and on failure die with
an explanation instead of a segv. Will do this.
Comment 6 Caolan McNamara 2006-10-31 12:09:17 EST
Fix checked in, will be in next update
Comment 7 Casey Harkins 2006-11-06 01:15:05 EST
For the record, we're seeing this bug with /home mounted over NFS.
Comment 8 Casey Harkins 2006-11-06 01:25:16 EST
(In reply to comment #7)
> For the record, we're seeing this bug with /home mounted over NFS.

That's NFS mounted with noexec option, which is obviously the problem after I
looked over the strace output above. Sorry for the bugzilla spam!

Note You need to log in before you can comment on or make changes to this bug.