Bug 21299 - tftp server will not allow uploads
tftp server will not allow uploads
Status: CLOSED DUPLICATE of bug 18128
Product: Red Hat Linux
Classification: Retired
Component: tftp (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-24 09:10 EST by Need Real Name
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-24 09:10:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-24 09:10:17 EST
I'm currently using tftp-server-0.17-5 and the patched version of xinetd 
from the redhat site. When I try to put a file to the /tftpboot directory, 
I get the following message:

Error Code 2: Access Violation.

Also, in the /var/log/secure file, the following:

Nov 24 08:03:27 server1 xinetd[3573] start: tftp pid=3580 from=x.x.x.x 
(note: x.x.x.x is the address of the linux box)

Nothing relating to the problem appears in the /var/log/messages file.

I am doing all of the testing from the linux box itself.  I have gone into 
the /tftpboot directory and created the file (touch testfile) and changed 
the rights on it (chmod 777 testfile).  I can, however download files from 
the tftp server all day long.  I posted a message to the redhat-list 
mailing list and was told that I needed to change back to tftp-server-0.16 
to be able to upload files.  Am I doing something wrong or missing 
something?  I really need to be able to upload files to the tftp server.  
Any help is much appreciated.
Comment 1 Pekka Savola 2000-11-25 05:04:51 EST
TFTP puts don't work with RHL7 tftp, you have to revert or patch it.

You should be getting timeouts, however, not access violation.  Most probably 
you're not using '-s' switch (for chroot) and trying to 'put test.file', not 'put /tftpboot/test.file'.

The previous version of tftpd was more allowing about that.


*** This bug has been marked as a duplicate of 18128 ***

Note You need to log in before you can comment on or make changes to this bug.