Bug 213003 - FC6 XFCE upgrade eradicates user's panel configuration
FC6 XFCE upgrade eradicates user's panel configuration
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 10:25 EST by Mark Bickford
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 14:52:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Bickford 2006-10-30 10:25:18 EST
Description of problem:  After upgrading an existing FC 5 installation with XFCE
to FC6, yum update updates the XFCE installation to XFCE 4.3.99.1.  Part of this
update includes xfce4-panel.  However, the new installation of XFCE Panel
appears to erase the previous user configuration and replace it with a default
configuration.  I am not sure if this is due to the Fedora package or if it
comes from upstream.


Version-Release number of selected component (if applicable):
xfce4-panel-4.3.99.1-7.fc6.i386.rpm.


How reproducible:


Steps to Reproduce:
1.  Create a Fedora Core 5 system with a customized XFCE 4 panel configuration.
2.  Upgrade to FC 6 using the October 23 ISO set.
3.  After the restart, log into GNOME and perform a yum -y update that includes
Extras.  You may need to repair any issues caused by bug 211941.
4.  Reboot and go into your XFCE session.
  
Actual results:
1.  XFCE Panel has a default configuration of buttons. 

Expected results:
1.  XFCE Panel has the previously-selected configuration, or else the previous
configuration is backed up and recoverable.

Additional info:
Comment 1 Kevin Fenzi 2006-10-30 14:35:08 EST
Alas, this is an upstream issue... The changes in the panel to support things
like multiple pannels and transparency, etc have made the old configuration not
usable with the new version. 

See the debian bug at: 
http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/2006-June/001922.html

I'll do some more looking around and see if there is anything further to be done
to get around the problem, but it doesn't look too promising. 
Comment 2 Kevin Fenzi 2006-11-29 14:52:20 EST
I don't see any way to work around this... 4.4 uses a diffrent config format.

See also: 
http://bugzilla.xfce.org/show_bug.cgi?id=2482

I am going to go ahead and close this bug now. If anyone comes up with a
solution, I would love to hear it. 

Sorry for the trouble in reconfiguring your panel settings. ;( 

Note You need to log in before you can comment on or make changes to this bug.