Bug 2130087 - Firefox cause flickering context menus on websites since 105.1 on wayland
Summary: Firefox cause flickering context menus on websites since 105.1 on wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F37FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-09-27 06:58 UTC by GroovieMan
Modified: 2022-12-12 15:26 UTC (History)
14 users (show)

Fixed In Version: firefox-105.0.1-2.fc37 firefox-105.0.2-1.fc38 firefox-105.0.2-1.fc36 firefox-105.0.2-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-04 15:12:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Video showing the problem. (2.51 MB, video/webm)
2022-09-29 13:09 UTC, Lukas Ruzicka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 1791856 0 P3 RESOLVED Context menu disappear on hover 2022-09-29 21:11:36 UTC

Description GroovieMan 2022-09-27 06:58:22 UTC
Description of problem:
Recent update of firefox (->firefox-105.0.1-1.fc36.x86_64) shows flickering context menus (right mouse button) on a wayland display, especially when the mouse moves, to select one item. 
This happens after i made an update and has been seen all pages i visited.

Version-Release number of selected component (if applicable):
firefox-105.0.1-1.fc36.x86_64

How reproducible:
open a page with your firefox and try (for instance) to open an item in another windows tab. When you open with right mouseclick the context menu, the shown menu is flickering.

Steps to Reproduce:
1. open firefox
2. open a site (i.e. https://www.washingtonpost.com/)
3. locate your mouse on a hyperlink and try to open this page in a tabbed windows. So you click right-mouse-button and the you will notice a flickering menu.

Actual results:
flickering menu

Expected results:
stable menu

Additional info:

Comment 1 Martin Stransky 2022-09-27 08:22:34 UTC
I guess you use fractional scale, right?

Comment 2 GroovieMan 2022-09-27 08:47:37 UTC
When you are talking about "fractional scale" you mean the page scale mechanism of Firefox, that allows to enlarge or shrink the resolution of the shown page, am i right?
No, the flickering also appear, when you do not touch the scale control in the URL address field. Please not, that this problem did not occur before!

Leave me a note if i am wrong.

Comment 3 GroovieMan 2022-09-28 19:02:04 UTC
I checked it also on X11/Gnome, but firefox does not have these problems unter X11.
Maybe it is a Wayland issue?

Comment 4 Martin Stransky 2022-09-29 07:35:02 UTC
Does it help if you set widget.wayland.use-move-to-rect to false at about:config and restart browser?
Thanks.

Comment 5 Martin Stransky 2022-09-29 07:36:21 UTC
Should be covered by https://bugzilla.mozilla.org/show_bug.cgi?id=1791856 fixed in 107.

Comment 6 GroovieMan 2022-09-29 08:01:56 UTC
Yes it does!
Thank you.

Comment 7 GroovieMan 2022-09-29 08:23:46 UTC
The flickering gets extreme, when the mouse pointer is in the same region. This behaviour looks similar to the mozilla's bug description.

Comment 8 Lukas Ruzicka 2022-09-29 13:07:34 UTC
I am also experiencing this. No scaling (fractional or whole) applied. The proposed workaround works for me, too.

Comment 9 Fedora Blocker Bugs Application 2022-09-29 13:08:32 UTC
Proposed as a Blocker for 37-final by Fedora user lruzicka using the blocker tracking app because:

 Flickering of the context menus are a severe complication that violates the Basic Functionality criterion.

Comment 10 Lukas Ruzicka 2022-09-29 13:09:13 UTC
Created attachment 1915005 [details]
Video showing the problem.

Comment 11 Tomas Popela 2022-09-29 16:16:30 UTC
(In reply to Fedora Blocker Bugs Application from comment #9)
> Proposed as a Blocker for 37-final by Fedora user lruzicka using the blocker
> tracking app because:
> 
>  Flickering of the context menus are a severe complication that violates the
> Basic Functionality criterion.

Just a small note - that could mean that Fedora 37 will be released AFTER November 15, when Firefox 107 will be released, see:

(In reply to Martin Stransky from comment #5)
> Should be covered by https://bugzilla.mozilla.org/show_bug.cgi?id=1791856
> fixed in 107.

Comment 12 Ben Cotton 2022-09-29 21:11:37 UTC
How difficult would it be to backport the upstream fix to 105?

Comment 13 Martin Stransky 2022-09-30 08:04:06 UTC
Will do the backport then.

Comment 14 Martin Stransky 2022-09-30 08:34:55 UTC
Added to firefox-105.0.1-2, let's see how it works.

Comment 15 Adam Williamson 2022-09-30 16:35:14 UTC
Setting POST, as it seems so far the backport is only done for Rawhide.

Comment 16 Adam Williamson 2022-09-30 16:36:27 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/929 , marking accepted. (Though I can't reproduce this even though I'm on 105.0.1 on Wayland with fractional scaling. Oh, well.)

Martin, assuming the backport works, this means we need it built for F37 too ASAP, thanks!

Comment 17 Martin Stransky 2022-10-03 10:05:50 UTC
(In reply to Adam Williamson from comment #16)
> +4 in https://pagure.io/fedora-qa/blocker-review/issue/929 , marking
> accepted. (Though I can't reproduce this even though I'm on 105.0.1 on
> Wayland with fractional scaling. Oh, well.)
> 
> Martin, assuming the backport works, this means we need it built for F37 too
> ASAP, thanks!

I did the build for all branches, it's done now:
https://koji.fedoraproject.org/koji/buildinfo?buildID=2069042

Will do an update.

Comment 18 Fedora Update System 2022-10-03 10:07:14 UTC
FEDORA-2022-363c122092 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-363c122092

Comment 19 Fedora Update System 2022-10-03 10:07:16 UTC
FEDORA-2022-8c066873cc has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-8c066873cc

Comment 20 Fedora Update System 2022-10-03 10:07:17 UTC
FEDORA-2022-c1ff6ec13b has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-c1ff6ec13b

Comment 21 Fedora Update System 2022-10-04 01:22:49 UTC
FEDORA-2022-c1ff6ec13b has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-c1ff6ec13b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-c1ff6ec13b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2022-10-04 01:44:48 UTC
FEDORA-2022-363c122092 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-363c122092`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-363c122092

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Update System 2022-10-04 02:01:33 UTC
FEDORA-2022-8c066873cc has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-8c066873cc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-8c066873cc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 24 Fedora Update System 2022-10-04 15:12:24 UTC
FEDORA-2022-c1ff6ec13b has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 25 Fedora Update System 2022-10-05 12:46:01 UTC
FEDORA-2022-f0988ea008 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f0988ea008

Comment 26 Fedora Update System 2022-10-05 12:57:39 UTC
FEDORA-2022-f0988ea008 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 27 Fedora Update System 2022-10-06 15:15:03 UTC
FEDORA-2022-48d3ccebe6 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 28 Fedora Update System 2022-10-06 16:45:50 UTC
FEDORA-2022-f02122afc2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-f02122afc2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f02122afc2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 29 Fedora Update System 2022-10-18 15:43:01 UTC
FEDORA-2022-f02122afc2 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.