Bug 213092 - FC6 fails to boot on a single-core PowerMac G5.
FC6 fails to boot on a single-core PowerMac G5.
Status: CLOSED DUPLICATE of bug 214494
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
ppc64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 15:06 EST by Andreas Gal
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 13:23:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Gal 2006-10-30 15:06:15 EST
Description of problem: After installation kernel boot fails during communication with prom (right after 
returning from prom_init).

Version-Release number of selected component (if applicable): Apple PowerMac7,2 5.1.5f1 BootROM 
built on 08/25/04 at 10:43:05. This is a PowerMac G5 single core.

How reproducible: Always (but crash looks different sometimes, see below)

Steps to Reproduce:
1. Install FC6, boot machine.
  
Actual results:

Machine crashes in two different ways (randomly)

scenario 1: "returning from prom_init" followed by Invalid memory access at  %SRR0: 
00000000.01403984    %SRR1:   10000000.00083030

Apple PowerMac7,2 ... (rest of prom start text, followed by a prompt but machine is locked up and no 
keyboard input possible). Restarting with power button on monitor is possible.

scenario 2: as above, but no prompt. Instead "Release keys to continue!" Restart with power button not 
possible. Need to pull power.

Expected results:

Boot. 

Additional info:

I never managed to get any FC to run on this machine. The installer kernels work just fine, the actual 
installed kernels do not. Why don't you ship a more reliable baseline kernel (same as installer) and an 
optional optimized kernel??
Comment 1 Andreas Gal 2006-10-30 20:46:53 EST
Using the rescue mode I logged in and it turns out that the wrong kernel was installed (ppc32). I removed 
the kernel with rpm and installed the kernel.ppc64 kernel. The system then boots past the point above, 
but then prints

hwclock: settimeofday() failed, errno=22: Invalid argument
Setting clock (utc): Thu Dec 31 16:29:15 PST 1903
Starting udev:

and the machine hangs. Did anyone ever boot FC6 on a ppc64 before releasing it? Just wondering =). The 
32-bit kernel should at least complain that its incompatible or something.
Comment 2 Andreas Gal 2006-10-30 21:11:23 EST
I restarted the machine and logged in via rescue mode. Trying to set the date with "date -s" fails. "ntpdate 
time.apple.com" freezes the machine hard.
Comment 3 David Woodhouse 2006-11-22 13:23:26 EST
Yes, my primary workstation is FC6/PPC64. Your date problem seems to be that the
PMU has reset itself. Booting to runlevel 1 and setting the date should work
fine -- userspace has bugs when it thinks it's running in 1904, and doesn't even
let you log in on the console as root :)

You can also set the date from OF.



*** This bug has been marked as a duplicate of 214494 ***

Note You need to log in before you can comment on or make changes to this bug.