Bug 2130943 - F37 background format being changed to webp breaks LXDE background
Summary: F37 background format being changed to webp breaks LXDE background
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: lxdm
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F37FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-09-29 14:10 UTC by Mamoru TASAKA
Modified: 2022-11-13 01:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-13 01:21:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Mamoru TASAKA 2022-09-29 14:10:09 UTC
Description of problem:
With https://bodhi.fedoraproject.org/updates/FEDORA-2022-a5622b766b Fedora 37 default wallpaper changes the format from png to webp, breaking LXDE spin background

Version-Release number of selected component (if applicable):
lxdm-0.5.3-22.D20220831git2d4ba970.fc37
f37-backgrounds-37.0.2-1.fc37
desktop-backgrounds-37.0.0-2.fc37

How reproducible:
100%

Steps to Reproduce:
1. Apply FEDORA-2022-a5622b766b update
2. Try to login to LXDE session, using LXDM login manager
3.

Actual results:
LXDM login manager, LXDE session both shows static color background, no Stonehenge-like F37 default background


Additional info:
/etc/lxdm/lxdm.conf contains

Comment 1 Fedora Update System 2022-09-29 14:35:15 UTC
FEDORA-2022-13f3b289b2 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-13f3b289b2

Comment 2 Mamoru TASAKA 2022-09-29 23:46:10 UTC
Once I've revoked this - I am waiting for final decision for https://bodhi.fedoraproject.org/updates/FEDORA-2022-a5622b766b

Comment 3 Fedora Blocker Bugs Application 2022-09-29 23:48:52 UTC
Proposed as a Freeze Exception for 37-final by Fedora user mtasaka using the blocker tracking app because:

 https://bodhi.fedoraproject.org/updates/FEDORA-2022-a5622b766b (when accepted) is going to break LXDE Live / installed desktop background, degress usability

Comment 4 František Zatloukal 2022-10-03 11:56:34 UTC
Discussed in ticket: https://pagure.io/fedora-qa/blocker-review/issue/937

The decision to classify this bug as an AcceptedFreezeException was made.

Comment 5 Mamoru TASAKA 2022-11-13 01:21:51 UTC
I believe for at least for F-37 we no longer have to modify LXDE side.
Once closing.


Note You need to log in before you can comment on or make changes to this bug.