Bug 213110 - stage 2 netconfig needs to be orthogonal for IP stacks
stage 2 netconfig needs to be orthogonal for IP stacks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
: OtherQA
: 232596 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 15:42 EST by David Cantrell
Modified: 2010-10-22 02:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0644
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:18:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-RHEL-5-orthogonal-stage2-netconfig.patch (114.15 KB, patch)
2007-05-29 17:07 EDT, David Cantrell
no flags Details | Diff

  None (edit)
Description David Cantrell 2006-10-30 15:42:43 EST
Like bug #213108, the stage 2 network configuration screen should allow DHCP or
manual configuration per IP stack rather than across all stacks.
Comment 1 David Cantrell 2007-05-03 11:47:25 EDT
Setting devel-ack and exception flag.

In RHEL-5.0, the stage 2 network configuration screen does not a user to
independently configure IPv4 and IPv6 stacks.  If you want DHCP, you get it on
all stacks.  You cannot configure static IPv4 and then DHCP for IPv6.  This is
incorrect and should be fixed.  IP stack configuration must be independent.

I have corrected the user interface in rawhide when I first filed this bug and
all I need to do is bring the code over to the RHEL-5 tree.  Users can
independently configure IPv4 and IPv6 stacks in this updated user interface.
Comment 2 RHEL Product and Program Management 2007-05-03 12:05:42 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 James Laska 2007-05-03 12:19:37 EDT
Adding QA_ACK for 5.1

David: can you think of any specific test scenarios you would like to see?  Will
there need to be installation documentation changes to reflect the UI differences?

Comment 4 David Cantrell 2007-05-03 15:02:50 EDT
The main stage 2 netconfig UI in graphical mode will look the same.  The window
that opens to fill in the blanks for each interface will be different.  So yes, 
documentation changes will be required.

Documentation changes will also be required for the text mode stage 2 netconfig
UI since it has been changed to more closely resemble the graphical mode.

Test scenarios I can think of:
- IPv4 anything, no IPv6
- no IPv4, IPv6 anything
- IPv6 static
- IPv4 static
- Entering a CIDR prefix and the netmask computing correctly
- Entering an invalid IP address (both stacks)
- Entering an invalid netmask
- Entering an invalid CIDR prefix
- Entering an invalid IPv6 prefix

Nothing should cause a trace back.
Comment 5 David Cantrell 2007-05-29 17:07:52 EDT
Created attachment 155632 [details]
anaconda-RHEL-5-orthogonal-stage2-netconfig.patch
Comment 7 David Cantrell 2007-07-24 13:44:41 EDT
*** Bug 232596 has been marked as a duplicate of this bug. ***
Comment 8 John Poelstra 2007-08-24 01:15:57 EDT
A fix for this issue should have been included in the packages contained in the
most recent snapshot (partners.redhat.com) for RHEL5.1.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 9 James Laska 2007-08-27 15:09:07 EDT
VERIFIED in RHEL5.1 snapshot#4 (RHEL5.1-Server-20070822.1)

Tried the following combinations:

 - dynamic ipv4, dynamic local ipv6
 - static ipv4, dynamic local ipv6
 - static ipv4, static local ipv6
 - dynamic ipv4, static local ipv6

All /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-ethN
settings matched the expected result.
Comment 13 errata-xmlrpc 2007-11-07 12:18:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0644.html

Note You need to log in before you can comment on or make changes to this bug.