Bug 213111 - upgrade fails because of RAID1 setup
upgrade fails because of RAID1 setup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 15:45 EST by Vladimir Kotal
Modified: 2009-01-25 13:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 13:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kotal 2006-10-30 15:45:00 EST
Description of problem:
I am running anaconda from FC6 install DVD and after it correctly detected my
FC5 installation it displayed following message:

'Multiple devices on your system are labelled /home/media. Labels across devices
must be unique for your system to function properly.

Please fix this problem and restart the installation process.'


Version-Release number of selected component (if applicable):
anaconda package from FC6 install DVD (i386)

How reproducible:
insert FC6 install DVD, try to upgrade FC5 system

Steps to Reproduce:
1. insert FC6 DVD
2. proceed to upgrade
  
Actual results:
the above message is displayed, cannot continue install process.

Expected results:
install process should go on.

Additional info:
I belive this has something to do with my RAID1 setup via md. There are two
devices set to be in RAID1 - /dev/sda1, /dev/sdb1. All is done via /etc/mdconf
Comment 1 Vladimir Kotal 2006-10-30 15:53:22 EST
I have verified that /dev/md0, /dev/sda1, /dev/sdb1 indeed contain the same
label ('/home/media') via e2label(8). I think I will mess up my RAID1 setup if I
change that, am I correct ? If it is so then this is bug in anaconda.
Comment 2 Vladimir Kotal 2006-10-30 17:25:30 EST
I have used the following workaround:

1. remove /dev/md0 from /etc/fstab
2. move /etc/mdadm.conf to /etc/mdadm.conf.disabled
3. disconnect sda1, sdb1 from SATA cables (physically)
4. reboot from FC6 DVD
5. upgrade the system
6. get the RAID configuration back

After that I have booted FC6 from upgraded hard-drive and everything was fine.

Could someone plase confirm that this is a bug ?
Comment 3 Chris Lumens 2006-11-09 15:16:30 EST
Yeah, looks like this is even a known bug according to this comment in fsset.py:

# XXX fix RAID
def readFstab (path, intf = None):
Comment 4 Chris Lumens 2006-11-09 15:50:44 EST
What does /etc/fstab look like on the system you are trying to upgrade?
Comment 5 Vladimir Kotal 2006-11-09 18:13:19 EST
This is the way it looks after upgrade:

/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
#LABEL=/home/media       /home/media             ext3    defaults        1 2
# /home/media je RAID 1 (mirror) of /dev/sda1 and /dev/sdb1
# /dev/md0 nekontrolovat via fsck - proto "0 0"
/dev/md0                /home/media             ext3    defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0


I am pretty sure it looked the same before the upgrade.
Comment 6 Vladimir Kotal 2007-06-16 14:15:47 EDT
This bug is still present in FC7. I had to go through the dirty cable work again :)
Comment 7 Vladimir Kotal 2007-11-10 07:03:12 EST
This is still present in FC8. I had to open the case and disconnect the disks in RAID in order to complete 
the upgrade. It's interesting notion - in order to modify software one has to modify the hardware.. Is this 
really so hard to fix this ?
Comment 8 Bug Zapper 2008-04-04 00:16:47 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 9 Vladimir Kotal 2008-04-06 16:03:41 EDT
This bug is still present in the upgrade program in FC8.
Comment 10 Chris Lumens 2008-08-27 13:30:03 EDT
Please give F10 Beta a try.  I've since removed the code that checks for duplicate labels in all cases, except if you have LABEL= in your fstab.  In that case if multiple things are labelled the same, we really will have to error out.  However if you're not actually using the label in your /etc/fstab (which it looks like you aren't), there's no reason we should be checking and failing there.
Comment 11 Chris Spencer 2009-01-25 13:00:16 EST
This bug is still present in F10. I tried upgrading from F8 to F10, and I received this same error. It's a show-stopper. Please re-open this ticket.

Note You need to log in before you can comment on or make changes to this bug.